summaryrefslogtreecommitdiffstats
path: root/vendor/crossbeam-queue/Cargo.toml
diff options
context:
space:
mode:
Diffstat (limited to 'vendor/crossbeam-queue/Cargo.toml')
-rw-r--r--vendor/crossbeam-queue/Cargo.toml51
1 files changed, 51 insertions, 0 deletions
diff --git a/vendor/crossbeam-queue/Cargo.toml b/vendor/crossbeam-queue/Cargo.toml
new file mode 100644
index 000000000..c8093dc19
--- /dev/null
+++ b/vendor/crossbeam-queue/Cargo.toml
@@ -0,0 +1,51 @@
+# THIS FILE IS AUTOMATICALLY GENERATED BY CARGO
+#
+# When uploading crates to the registry Cargo will automatically
+# "normalize" Cargo.toml files for maximal compatibility
+# with all versions of Cargo and also rewrite `path` dependencies
+# to registry (e.g., crates.io) dependencies.
+#
+# If you are reading this file be aware that the original Cargo.toml
+# will likely look very different (and much more reasonable).
+# See Cargo.toml.orig for the original contents.
+
+[package]
+edition = "2018"
+rust-version = "1.36"
+name = "crossbeam-queue"
+version = "0.3.5"
+description = "Concurrent queues"
+homepage = "https://github.com/crossbeam-rs/crossbeam/tree/master/crossbeam-queue"
+keywords = [
+ "queue",
+ "mpmc",
+ "lock-free",
+ "producer",
+ "consumer",
+]
+categories = [
+ "concurrency",
+ "data-structures",
+ "no-std",
+]
+license = "MIT OR Apache-2.0"
+repository = "https://github.com/crossbeam-rs/crossbeam"
+
+[dependencies.cfg-if]
+version = "1"
+
+[dependencies.crossbeam-utils]
+version = "0.8.5"
+default-features = false
+
+[dev-dependencies.rand]
+version = "0.8"
+
+[features]
+alloc = []
+default = ["std"]
+nightly = ["crossbeam-utils/nightly"]
+std = [
+ "alloc",
+ "crossbeam-utils/std",
+]