summaryrefslogtreecommitdiffstats
path: root/vendor/crossbeam/Cargo.toml
diff options
context:
space:
mode:
Diffstat (limited to 'vendor/crossbeam/Cargo.toml')
-rw-r--r--vendor/crossbeam/Cargo.toml59
1 files changed, 59 insertions, 0 deletions
diff --git a/vendor/crossbeam/Cargo.toml b/vendor/crossbeam/Cargo.toml
new file mode 100644
index 000000000..71710f835
--- /dev/null
+++ b/vendor/crossbeam/Cargo.toml
@@ -0,0 +1,59 @@
+# THIS FILE IS AUTOMATICALLY GENERATED BY CARGO
+#
+# When uploading crates to the registry Cargo will automatically
+# "normalize" Cargo.toml files for maximal compatibility
+# with all versions of Cargo and also rewrite `path` dependencies
+# to registry (e.g., crates.io) dependencies
+#
+# If you believe there's an error in this file please file an
+# issue against the rust-lang/cargo repository. If you're
+# editing this file be aware that the upstream Cargo.toml
+# will likely look very different (and much more reasonable)
+
+[package]
+edition = "2018"
+name = "crossbeam"
+version = "0.8.1"
+authors = ["The Crossbeam Project Developers"]
+exclude = ["/.github", "/ci"]
+description = "Tools for concurrent programming"
+homepage = "https://github.com/crossbeam-rs/crossbeam"
+documentation = "https://docs.rs/crossbeam"
+keywords = ["atomic", "garbage", "non-blocking", "lock-free", "rcu"]
+categories = ["concurrency", "memory-management", "data-structures", "no-std"]
+license = "MIT OR Apache-2.0"
+repository = "https://github.com/crossbeam-rs/crossbeam"
+[dependencies.cfg-if]
+version = "1"
+
+[dependencies.crossbeam-channel]
+version = "0.5"
+optional = true
+default-features = false
+
+[dependencies.crossbeam-deque]
+version = "0.8"
+optional = true
+default-features = false
+
+[dependencies.crossbeam-epoch]
+version = "0.9.5"
+optional = true
+default-features = false
+
+[dependencies.crossbeam-queue]
+version = "0.3.2"
+optional = true
+default-features = false
+
+[dependencies.crossbeam-utils]
+version = "0.8.5"
+default-features = false
+[dev-dependencies.rand]
+version = "0.8"
+
+[features]
+alloc = ["crossbeam-epoch/alloc", "crossbeam-queue/alloc"]
+default = ["std"]
+nightly = ["crossbeam-epoch/nightly", "crossbeam-utils/nightly", "crossbeam-queue/nightly"]
+std = ["alloc", "crossbeam-channel/std", "crossbeam-deque/std", "crossbeam-epoch/std", "crossbeam-queue/std", "crossbeam-utils/std"]