summaryrefslogtreecommitdiffstats
path: root/vendor/crypto-common/Cargo.toml
diff options
context:
space:
mode:
Diffstat (limited to 'vendor/crypto-common/Cargo.toml')
-rw-r--r--vendor/crypto-common/Cargo.toml20
1 files changed, 16 insertions, 4 deletions
diff --git a/vendor/crypto-common/Cargo.toml b/vendor/crypto-common/Cargo.toml
index acbb81329..cfac76fa9 100644
--- a/vendor/crypto-common/Cargo.toml
+++ b/vendor/crypto-common/Cargo.toml
@@ -12,18 +12,29 @@
[package]
edition = "2018"
name = "crypto-common"
-version = "0.1.3"
+version = "0.1.6"
authors = ["RustCrypto Developers"]
description = "Common cryptographic traits"
documentation = "https://docs.rs/crypto-common"
readme = "README.md"
-keywords = ["crypto", "traits"]
-categories = ["cryptography", "no-std"]
+keywords = [
+ "crypto",
+ "traits",
+]
+categories = [
+ "cryptography",
+ "no-std",
+]
license = "MIT OR Apache-2.0"
repository = "https://github.com/RustCrypto/traits"
+
[package.metadata.docs.rs]
all-features = true
-rustdoc-args = ["--cfg", "docsrs"]
+rustdoc-args = [
+ "--cfg",
+ "docsrs",
+]
+
[dependencies.generic-array]
version = "0.14.4"
features = ["more_lengths"]
@@ -36,4 +47,5 @@ optional = true
version = "1.14"
[features]
+getrandom = ["rand_core/getrandom"]
std = []