summaryrefslogtreecommitdiffstats
path: root/vendor/crypto-common
diff options
context:
space:
mode:
Diffstat (limited to 'vendor/crypto-common')
-rw-r--r--vendor/crypto-common/.cargo-checksum.json1
-rw-r--r--vendor/crypto-common/CHANGELOG.md29
-rw-r--r--vendor/crypto-common/Cargo.toml39
-rw-r--r--vendor/crypto-common/LICENSE-APACHE201
-rw-r--r--vendor/crypto-common/LICENSE-MIT25
-rw-r--r--vendor/crypto-common/README.md53
-rw-r--r--vendor/crypto-common/src/lib.rs300
7 files changed, 648 insertions, 0 deletions
diff --git a/vendor/crypto-common/.cargo-checksum.json b/vendor/crypto-common/.cargo-checksum.json
new file mode 100644
index 000000000..4043ecbfc
--- /dev/null
+++ b/vendor/crypto-common/.cargo-checksum.json
@@ -0,0 +1 @@
+{"files":{"CHANGELOG.md":"77f7a114f0d472c5a2eae818ddb81d3997d8d28373bf16b996d45d07ca3765e5","Cargo.toml":"557171ee4c07cad91539344fa0f87752c3104d39706ff7549af3decaac293e11","LICENSE-APACHE":"a9040321c3712d8fd0b09cf52b17445de04a23a10165049ae187cd39e5c86be5","LICENSE-MIT":"3521672491a3479422d5fe1aca6645dd2984090f85da6e5205abfb18fb7a6897","README.md":"3451ce2bc0b658041902a8e792023d9874700e9292eac9153c45f203430e24a0","src/lib.rs":"a6247fa4e20bc84d5a371f76c334b57e5fed3c8758976b2a29296904fb2a0007"},"package":"57952ca27b5e3606ff4dd79b0020231aaf9d6aa76dc05fd30137538c50bd3ce8"} \ No newline at end of file
diff --git a/vendor/crypto-common/CHANGELOG.md b/vendor/crypto-common/CHANGELOG.md
new file mode 100644
index 000000000..ebd278695
--- /dev/null
+++ b/vendor/crypto-common/CHANGELOG.md
@@ -0,0 +1,29 @@
+# Changelog
+
+All notable changes to this project will be documented in this file.
+
+The format is based on [Keep a Changelog](https://keepachangelog.com/en/1.0.0/),
+and this project adheres to [Semantic Versioning](https://semver.org/spec/v2.0.0.html).
+
+## 0.1.3 (2022-02-16)
+### Fixed
+- Minimal versions build ([#940])
+
+[#940]: https://github.com/RustCrypto/traits/pull/940
+
+## 0.1.2 (2022-02-10)
+### Added
+- Re-export `generic-array` and `typenum`. Enable `more_lengths` feature on
+`generic-array`. Add `key_size`, `iv_size`, `block_size`, and `output_size`
+helper methods. ([#849])
+
+[#849]: https://github.com/RustCrypto/traits/pull/849
+
+## 0.1.1 (2021-12-14)
+### Added
+- `rand_core` re-export and proper exposure of key/IV generation methods on docs.rs ([#847])
+
+[#847]: https://github.com/RustCrypto/traits/pull/847
+
+## 0.1.0 (2021-12-07)
+- Initial release
diff --git a/vendor/crypto-common/Cargo.toml b/vendor/crypto-common/Cargo.toml
new file mode 100644
index 000000000..acbb81329
--- /dev/null
+++ b/vendor/crypto-common/Cargo.toml
@@ -0,0 +1,39 @@
+# THIS FILE IS AUTOMATICALLY GENERATED BY CARGO
+#
+# When uploading crates to the registry Cargo will automatically
+# "normalize" Cargo.toml files for maximal compatibility
+# with all versions of Cargo and also rewrite `path` dependencies
+# to registry (e.g., crates.io) dependencies.
+#
+# If you are reading this file be aware that the original Cargo.toml
+# will likely look very different (and much more reasonable).
+# See Cargo.toml.orig for the original contents.
+
+[package]
+edition = "2018"
+name = "crypto-common"
+version = "0.1.3"
+authors = ["RustCrypto Developers"]
+description = "Common cryptographic traits"
+documentation = "https://docs.rs/crypto-common"
+readme = "README.md"
+keywords = ["crypto", "traits"]
+categories = ["cryptography", "no-std"]
+license = "MIT OR Apache-2.0"
+repository = "https://github.com/RustCrypto/traits"
+[package.metadata.docs.rs]
+all-features = true
+rustdoc-args = ["--cfg", "docsrs"]
+[dependencies.generic-array]
+version = "0.14.4"
+features = ["more_lengths"]
+
+[dependencies.rand_core]
+version = "0.6"
+optional = true
+
+[dependencies.typenum]
+version = "1.14"
+
+[features]
+std = []
diff --git a/vendor/crypto-common/LICENSE-APACHE b/vendor/crypto-common/LICENSE-APACHE
new file mode 100644
index 000000000..78173fa2e
--- /dev/null
+++ b/vendor/crypto-common/LICENSE-APACHE
@@ -0,0 +1,201 @@
+ Apache License
+ Version 2.0, January 2004
+ http://www.apache.org/licenses/
+
+TERMS AND CONDITIONS FOR USE, REPRODUCTION, AND DISTRIBUTION
+
+1. Definitions.
+
+ "License" shall mean the terms and conditions for use, reproduction,
+ and distribution as defined by Sections 1 through 9 of this document.
+
+ "Licensor" shall mean the copyright owner or entity authorized by
+ the copyright owner that is granting the License.
+
+ "Legal Entity" shall mean the union of the acting entity and all
+ other entities that control, are controlled by, or are under common
+ control with that entity. For the purposes of this definition,
+ "control" means (i) the power, direct or indirect, to cause the
+ direction or management of such entity, whether by contract or
+ otherwise, or (ii) ownership of fifty percent (50%) or more of the
+ outstanding shares, or (iii) beneficial ownership of such entity.
+
+ "You" (or "Your") shall mean an individual or Legal Entity
+ exercising permissions granted by this License.
+
+ "Source" form shall mean the preferred form for making modifications,
+ including but not limited to software source code, documentation
+ source, and configuration files.
+
+ "Object" form shall mean any form resulting from mechanical
+ transformation or translation of a Source form, including but
+ not limited to compiled object code, generated documentation,
+ and conversions to other media types.
+
+ "Work" shall mean the work of authorship, whether in Source or
+ Object form, made available under the License, as indicated by a
+ copyright notice that is included in or attached to the work
+ (an example is provided in the Appendix below).
+
+ "Derivative Works" shall mean any work, whether in Source or Object
+ form, that is based on (or derived from) the Work and for which the
+ editorial revisions, annotations, elaborations, or other modifications
+ represent, as a whole, an original work of authorship. For the purposes
+ of this License, Derivative Works shall not include works that remain
+ separable from, or merely link (or bind by name) to the interfaces of,
+ the Work and Derivative Works thereof.
+
+ "Contribution" shall mean any work of authorship, including
+ the original version of the Work and any modifications or additions
+ to that Work or Derivative Works thereof, that is intentionally
+ submitted to Licensor for inclusion in the Work by the copyright owner
+ or by an individual or Legal Entity authorized to submit on behalf of
+ the copyright owner. For the purposes of this definition, "submitted"
+ means any form of electronic, verbal, or written communication sent
+ to the Licensor or its representatives, including but not limited to
+ communication on electronic mailing lists, source code control systems,
+ and issue tracking systems that are managed by, or on behalf of, the
+ Licensor for the purpose of discussing and improving the Work, but
+ excluding communication that is conspicuously marked or otherwise
+ designated in writing by the copyright owner as "Not a Contribution."
+
+ "Contributor" shall mean Licensor and any individual or Legal Entity
+ on behalf of whom a Contribution has been received by Licensor and
+ subsequently incorporated within the Work.
+
+2. Grant of Copyright License. Subject to the terms and conditions of
+ this License, each Contributor hereby grants to You a perpetual,
+ worldwide, non-exclusive, no-charge, royalty-free, irrevocable
+ copyright license to reproduce, prepare Derivative Works of,
+ publicly display, publicly perform, sublicense, and distribute the
+ Work and such Derivative Works in Source or Object form.
+
+3. Grant of Patent License. Subject to the terms and conditions of
+ this License, each Contributor hereby grants to You a perpetual,
+ worldwide, non-exclusive, no-charge, royalty-free, irrevocable
+ (except as stated in this section) patent license to make, have made,
+ use, offer to sell, sell, import, and otherwise transfer the Work,
+ where such license applies only to those patent claims licensable
+ by such Contributor that are necessarily infringed by their
+ Contribution(s) alone or by combination of their Contribution(s)
+ with the Work to which such Contribution(s) was submitted. If You
+ institute patent litigation against any entity (including a
+ cross-claim or counterclaim in a lawsuit) alleging that the Work
+ or a Contribution incorporated within the Work constitutes direct
+ or contributory patent infringement, then any patent licenses
+ granted to You under this License for that Work shall terminate
+ as of the date such litigation is filed.
+
+4. Redistribution. You may reproduce and distribute copies of the
+ Work or Derivative Works thereof in any medium, with or without
+ modifications, and in Source or Object form, provided that You
+ meet the following conditions:
+
+ (a) You must give any other recipients of the Work or
+ Derivative Works a copy of this License; and
+
+ (b) You must cause any modified files to carry prominent notices
+ stating that You changed the files; and
+
+ (c) You must retain, in the Source form of any Derivative Works
+ that You distribute, all copyright, patent, trademark, and
+ attribution notices from the Source form of the Work,
+ excluding those notices that do not pertain to any part of
+ the Derivative Works; and
+
+ (d) If the Work includes a "NOTICE" text file as part of its
+ distribution, then any Derivative Works that You distribute must
+ include a readable copy of the attribution notices contained
+ within such NOTICE file, excluding those notices that do not
+ pertain to any part of the Derivative Works, in at least one
+ of the following places: within a NOTICE text file distributed
+ as part of the Derivative Works; within the Source form or
+ documentation, if provided along with the Derivative Works; or,
+ within a display generated by the Derivative Works, if and
+ wherever such third-party notices normally appear. The contents
+ of the NOTICE file are for informational purposes only and
+ do not modify the License. You may add Your own attribution
+ notices within Derivative Works that You distribute, alongside
+ or as an addendum to the NOTICE text from the Work, provided
+ that such additional attribution notices cannot be construed
+ as modifying the License.
+
+ You may add Your own copyright statement to Your modifications and
+ may provide additional or different license terms and conditions
+ for use, reproduction, or distribution of Your modifications, or
+ for any such Derivative Works as a whole, provided Your use,
+ reproduction, and distribution of the Work otherwise complies with
+ the conditions stated in this License.
+
+5. Submission of Contributions. Unless You explicitly state otherwise,
+ any Contribution intentionally submitted for inclusion in the Work
+ by You to the Licensor shall be under the terms and conditions of
+ this License, without any additional terms or conditions.
+ Notwithstanding the above, nothing herein shall supersede or modify
+ the terms of any separate license agreement you may have executed
+ with Licensor regarding such Contributions.
+
+6. Trademarks. This License does not grant permission to use the trade
+ names, trademarks, service marks, or product names of the Licensor,
+ except as required for reasonable and customary use in describing the
+ origin of the Work and reproducing the content of the NOTICE file.
+
+7. Disclaimer of Warranty. Unless required by applicable law or
+ agreed to in writing, Licensor provides the Work (and each
+ Contributor provides its Contributions) on an "AS IS" BASIS,
+ WITHOUT WARRANTIES OR CONDITIONS OF ANY KIND, either express or
+ implied, including, without limitation, any warranties or conditions
+ of TITLE, NON-INFRINGEMENT, MERCHANTABILITY, or FITNESS FOR A
+ PARTICULAR PURPOSE. You are solely responsible for determining the
+ appropriateness of using or redistributing the Work and assume any
+ risks associated with Your exercise of permissions under this License.
+
+8. Limitation of Liability. In no event and under no legal theory,
+ whether in tort (including negligence), contract, or otherwise,
+ unless required by applicable law (such as deliberate and grossly
+ negligent acts) or agreed to in writing, shall any Contributor be
+ liable to You for damages, including any direct, indirect, special,
+ incidental, or consequential damages of any character arising as a
+ result of this License or out of the use or inability to use the
+ Work (including but not limited to damages for loss of goodwill,
+ work stoppage, computer failure or malfunction, or any and all
+ other commercial damages or losses), even if such Contributor
+ has been advised of the possibility of such damages.
+
+9. Accepting Warranty or Additional Liability. While redistributing
+ the Work or Derivative Works thereof, You may choose to offer,
+ and charge a fee for, acceptance of support, warranty, indemnity,
+ or other liability obligations and/or rights consistent with this
+ License. However, in accepting such obligations, You may act only
+ on Your own behalf and on Your sole responsibility, not on behalf
+ of any other Contributor, and only if You agree to indemnify,
+ defend, and hold each Contributor harmless for any liability
+ incurred by, or claims asserted against, such Contributor by reason
+ of your accepting any such warranty or additional liability.
+
+END OF TERMS AND CONDITIONS
+
+APPENDIX: How to apply the Apache License to your work.
+
+ To apply the Apache License to your work, attach the following
+ boilerplate notice, with the fields enclosed by brackets "[]"
+ replaced with your own identifying information. (Don't include
+ the brackets!) The text should be enclosed in the appropriate
+ comment syntax for the file format. We also recommend that a
+ file or class name and description of purpose be included on the
+ same "printed page" as the copyright notice for easier
+ identification within third-party archives.
+
+Copyright [yyyy] [name of copyright owner]
+
+Licensed under the Apache License, Version 2.0 (the "License");
+you may not use this file except in compliance with the License.
+You may obtain a copy of the License at
+
+ http://www.apache.org/licenses/LICENSE-2.0
+
+Unless required by applicable law or agreed to in writing, software
+distributed under the License is distributed on an "AS IS" BASIS,
+WITHOUT WARRANTIES OR CONDITIONS OF ANY KIND, either express or implied.
+See the License for the specific language governing permissions and
+limitations under the License.
diff --git a/vendor/crypto-common/LICENSE-MIT b/vendor/crypto-common/LICENSE-MIT
new file mode 100644
index 000000000..efb0b5f8b
--- /dev/null
+++ b/vendor/crypto-common/LICENSE-MIT
@@ -0,0 +1,25 @@
+Copyright (c) 2021 RustCrypto Developers
+
+Permission is hereby granted, free of charge, to any
+person obtaining a copy of this software and associated
+documentation files (the "Software"), to deal in the
+Software without restriction, including without
+limitation the rights to use, copy, modify, merge,
+publish, distribute, sublicense, and/or sell copies of
+the Software, and to permit persons to whom the Software
+is furnished to do so, subject to the following
+conditions:
+
+The above copyright notice and this permission notice
+shall be included in all copies or substantial portions
+of the Software.
+
+THE SOFTWARE IS PROVIDED "AS IS", WITHOUT WARRANTY OF
+ANY KIND, EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED
+TO THE WARRANTIES OF MERCHANTABILITY, FITNESS FOR A
+PARTICULAR PURPOSE AND NONINFRINGEMENT. IN NO EVENT
+SHALL THE AUTHORS OR COPYRIGHT HOLDERS BE LIABLE FOR ANY
+CLAIM, DAMAGES OR OTHER LIABILITY, WHETHER IN AN ACTION
+OF CONTRACT, TORT OR OTHERWISE, ARISING FROM, OUT OF OR
+IN CONNECTION WITH THE SOFTWARE OR THE USE OR OTHER
+DEALINGS IN THE SOFTWARE.
diff --git a/vendor/crypto-common/README.md b/vendor/crypto-common/README.md
new file mode 100644
index 000000000..70ca758cd
--- /dev/null
+++ b/vendor/crypto-common/README.md
@@ -0,0 +1,53 @@
+# RustCrypto: Common Cryptographic Traits
+
+[![crate][crate-image]][crate-link]
+[![Docs][docs-image]][docs-link]
+![Apache2/MIT licensed][license-image]
+![Rust Version][rustc-image]
+[![Project Chat][chat-image]][chat-link]
+[![Build Status][build-image]][build-link]
+
+Common traits used by cryptographic algorithms. Users should generally use
+higher-level trait crates instead of this one.
+
+[Documentation][docs-link]
+
+## Minimum Supported Rust Version
+
+Rust **1.41** or higher.
+
+Minimum supported Rust version can be changed in the future, but it will be
+done with a minor version bump.
+
+## SemVer Policy
+
+- All on-by-default features of this library are covered by SemVer
+- MSRV is considered exempt from SemVer as noted above
+
+## License
+
+Licensed under either of:
+
+ * [Apache License, Version 2.0](http://www.apache.org/licenses/LICENSE-2.0)
+ * [MIT license](http://opensource.org/licenses/MIT)
+
+at your option.
+
+### Contribution
+
+Unless you explicitly state otherwise, any contribution intentionally submitted
+for inclusion in the work by you, as defined in the Apache-2.0 license, shall be
+dual licensed as above, without any additional terms or conditions.
+
+[//]: # (badges)
+
+[crate-image]: https://img.shields.io/crates/v/crypto-common.svg
+[crate-link]: https://crates.io/crates/crypto-common
+[docs-image]: https://docs.rs/crypto-common/badge.svg
+[docs-link]: https://docs.rs/crypto-common/
+[license-image]: https://img.shields.io/badge/license-Apache2.0/MIT-blue.svg
+[rustc-image]: https://img.shields.io/badge/rustc-1.41+-blue.svg
+[chat-image]: https://img.shields.io/badge/zulip-join_chat-blue.svg
+[chat-link]: https://rustcrypto.zulipchat.com/#narrow/stream/260041-hashes
+[build-image]: https://github.com/RustCrypto/traits/workflows/crypto-common/badge.svg?branch=master&event=push
+[build-link]: https://github.com/RustCrypto/traits/actions?query=workflow%3Acrypto-common
diff --git a/vendor/crypto-common/src/lib.rs b/vendor/crypto-common/src/lib.rs
new file mode 100644
index 000000000..187b1ac42
--- /dev/null
+++ b/vendor/crypto-common/src/lib.rs
@@ -0,0 +1,300 @@
+//! Common cryptographic traits.
+
+#![no_std]
+#![cfg_attr(docsrs, feature(doc_cfg))]
+#![doc(
+ html_logo_url = "https://raw.githubusercontent.com/RustCrypto/media/6ee8e381/logo.svg",
+ html_favicon_url = "https://raw.githubusercontent.com/RustCrypto/media/6ee8e381/logo.svg",
+ html_root_url = "https://docs.rs/crypto-common/0.1.3"
+)]
+#![forbid(unsafe_code)]
+#![warn(missing_docs, rust_2018_idioms)]
+
+#[cfg(feature = "std")]
+extern crate std;
+
+#[cfg(feature = "rand_core")]
+pub use rand_core;
+
+pub use generic_array;
+pub use generic_array::typenum;
+
+use core::fmt;
+use generic_array::{typenum::Unsigned, ArrayLength, GenericArray};
+#[cfg(feature = "rand_core")]
+use rand_core::{CryptoRng, RngCore};
+
+/// Block on which [`BlockSizeUser`] implementors operate.
+pub type Block<B> = GenericArray<u8, <B as BlockSizeUser>::BlockSize>;
+/// Output array of [`OutputSizeUser`] implementors.
+pub type Output<T> = GenericArray<u8, <T as OutputSizeUser>::OutputSize>;
+/// Key used by [`KeySizeUser`] implementors.
+pub type Key<B> = GenericArray<u8, <B as KeySizeUser>::KeySize>;
+/// Initialization vector (nonce) used by [`IvSizeUser`] implementors.
+pub type Iv<B> = GenericArray<u8, <B as IvSizeUser>::IvSize>;
+
+/// Types which process data in blocks.
+pub trait BlockSizeUser {
+ /// Size of the block in bytes.
+ type BlockSize: ArrayLength<u8> + 'static;
+
+ /// Return block size in bytes.
+ fn block_size() -> usize {
+ Self::BlockSize::USIZE
+ }
+}
+
+impl<T: BlockSizeUser> BlockSizeUser for &T {
+ type BlockSize = T::BlockSize;
+}
+
+impl<T: BlockSizeUser> BlockSizeUser for &mut T {
+ type BlockSize = T::BlockSize;
+}
+
+/// Types which return data with the given size.
+pub trait OutputSizeUser {
+ /// Size of the output in bytes.
+ type OutputSize: ArrayLength<u8> + 'static;
+
+ /// Return output size in bytes.
+ fn output_size() -> usize {
+ Self::OutputSize::USIZE
+ }
+}
+
+/// Types which use key for initialization.
+///
+/// Generally it's used indirectly via [`KeyInit`] or [`KeyIvInit`].
+pub trait KeySizeUser {
+ /// Key size in bytes.
+ type KeySize: ArrayLength<u8> + 'static;
+
+ /// Return key size in bytes.
+ fn key_size() -> usize {
+ Self::KeySize::USIZE
+ }
+}
+
+/// Types which use initialization vector (nonce) for initialization.
+///
+/// Generally it's used indirectly via [`KeyIvInit`] or [`InnerIvInit`].
+pub trait IvSizeUser {
+ /// Initialization vector size in bytes.
+ type IvSize: ArrayLength<u8> + 'static;
+
+ /// Return IV size in bytes.
+ fn iv_size() -> usize {
+ Self::IvSize::USIZE
+ }
+}
+
+/// Types which use another type for initialization.
+///
+/// Generally it's used indirectly via [`InnerInit`] or [`InnerIvInit`].
+pub trait InnerUser {
+ /// Inner type.
+ type Inner;
+}
+
+/// Resettable types.
+pub trait Reset {
+ /// Reset state to its initial value.
+ fn reset(&mut self);
+}
+
+/// Trait which stores algorithm name constant, used in `Debug` implementations.
+pub trait AlgorithmName {
+ /// Write algorithm name into `f`.
+ fn write_alg_name(f: &mut fmt::Formatter<'_>) -> fmt::Result;
+}
+
+/// Types which can be initialized from key.
+pub trait KeyInit: KeySizeUser + Sized {
+ /// Create new value from fixed size key.
+ fn new(key: &Key<Self>) -> Self;
+
+ /// Create new value from variable size key.
+ fn new_from_slice(key: &[u8]) -> Result<Self, InvalidLength> {
+ if key.len() != Self::KeySize::to_usize() {
+ Err(InvalidLength)
+ } else {
+ Ok(Self::new(Key::<Self>::from_slice(key)))
+ }
+ }
+
+ /// Generate random key using the provided [`CryptoRng`].
+ #[cfg(feature = "rand_core")]
+ #[cfg_attr(docsrs, doc(cfg(feature = "rand_core")))]
+ #[inline]
+ fn generate_key(mut rng: impl CryptoRng + RngCore) -> Key<Self> {
+ let mut key = Key::<Self>::default();
+ rng.fill_bytes(&mut key);
+ key
+ }
+}
+
+/// Types which can be initialized from key and initialization vector (nonce).
+pub trait KeyIvInit: KeySizeUser + IvSizeUser + Sized {
+ /// Create new value from fixed length key and nonce.
+ fn new(key: &Key<Self>, iv: &Iv<Self>) -> Self;
+
+ /// Create new value from variable length key and nonce.
+ #[inline]
+ fn new_from_slices(key: &[u8], iv: &[u8]) -> Result<Self, InvalidLength> {
+ let key_len = Self::KeySize::USIZE;
+ let iv_len = Self::IvSize::USIZE;
+ if key.len() != key_len || iv.len() != iv_len {
+ Err(InvalidLength)
+ } else {
+ Ok(Self::new(
+ Key::<Self>::from_slice(key),
+ Iv::<Self>::from_slice(iv),
+ ))
+ }
+ }
+
+ /// Generate random key using the provided [`CryptoRng`].
+ #[cfg(feature = "rand_core")]
+ #[cfg_attr(docsrs, doc(cfg(feature = "rand_core")))]
+ #[inline]
+ fn generate_key(mut rng: impl CryptoRng + RngCore) -> Key<Self> {
+ let mut key = Key::<Self>::default();
+ rng.fill_bytes(&mut key);
+ key
+ }
+
+ /// Generate random IV using the provided [`CryptoRng`].
+ #[cfg(feature = "rand_core")]
+ #[cfg_attr(docsrs, doc(cfg(feature = "rand_core")))]
+ #[inline]
+ fn generate_iv(mut rng: impl CryptoRng + RngCore) -> Iv<Self> {
+ let mut iv = Iv::<Self>::default();
+ rng.fill_bytes(&mut iv);
+ iv
+ }
+
+ /// Generate random key and nonce using the provided [`CryptoRng`].
+ #[cfg(feature = "rand_core")]
+ #[cfg_attr(docsrs, doc(cfg(feature = "rand_core")))]
+ #[inline]
+ fn generate_key_iv(mut rng: impl CryptoRng + RngCore) -> (Key<Self>, Iv<Self>) {
+ (Self::generate_key(&mut rng), Self::generate_iv(&mut rng))
+ }
+}
+
+/// Types which can be initialized from another type (usually block ciphers).
+///
+/// Usually used for initializing types from block ciphers.
+pub trait InnerInit: InnerUser + Sized {
+ /// Initialize value from the `inner`.
+ fn inner_init(inner: Self::Inner) -> Self;
+}
+
+/// Types which can be initialized from another type and additional initialization
+/// vector/nonce.
+///
+/// Usually used for initializing types from block ciphers.
+pub trait InnerIvInit: InnerUser + IvSizeUser + Sized {
+ /// Initialize value using `inner` and `iv` array.
+ fn inner_iv_init(inner: Self::Inner, iv: &Iv<Self>) -> Self;
+
+ /// Initialize value using `inner` and `iv` slice.
+ fn inner_iv_slice_init(inner: Self::Inner, iv: &[u8]) -> Result<Self, InvalidLength> {
+ if iv.len() != Self::IvSize::to_usize() {
+ Err(InvalidLength)
+ } else {
+ Ok(Self::inner_iv_init(inner, Iv::<Self>::from_slice(iv)))
+ }
+ }
+
+ /// Generate random IV using the provided [`CryptoRng`].
+ #[cfg(feature = "rand_core")]
+ #[cfg_attr(docsrs, doc(cfg(feature = "rand_core")))]
+ #[inline]
+ fn generate_iv(mut rng: impl CryptoRng + RngCore) -> Iv<Self> {
+ let mut iv = Iv::<Self>::default();
+ rng.fill_bytes(&mut iv);
+ iv
+ }
+}
+
+impl<T> KeySizeUser for T
+where
+ T: InnerUser,
+ T::Inner: KeySizeUser,
+{
+ type KeySize = <T::Inner as KeySizeUser>::KeySize;
+}
+
+impl<T> KeyIvInit for T
+where
+ T: InnerIvInit,
+ T::Inner: KeyInit,
+{
+ #[inline]
+ fn new(key: &Key<Self>, iv: &Iv<Self>) -> Self {
+ Self::inner_iv_init(T::Inner::new(key), iv)
+ }
+
+ #[inline]
+ fn new_from_slices(key: &[u8], iv: &[u8]) -> Result<Self, InvalidLength> {
+ T::Inner::new_from_slice(key).and_then(|i| T::inner_iv_slice_init(i, iv))
+ }
+}
+
+impl<T> KeyInit for T
+where
+ T: InnerInit,
+ T::Inner: KeyInit,
+{
+ #[inline]
+ fn new(key: &Key<Self>) -> Self {
+ Self::inner_init(T::Inner::new(key))
+ }
+
+ #[inline]
+ fn new_from_slice(key: &[u8]) -> Result<Self, InvalidLength> {
+ T::Inner::new_from_slice(key)
+ .map_err(|_| InvalidLength)
+ .map(Self::inner_init)
+ }
+}
+
+// Unfortunately this blanket impl is impossible without mutually
+// exclusive traits, see: https://github.com/rust-lang/rfcs/issues/1053
+// or at the very least without: https://github.com/rust-lang/rust/issues/20400
+/*
+impl<T> KeyIvInit for T
+where
+ T: InnerInit,
+ T::Inner: KeyIvInit,
+{
+ #[inline]
+ fn new(key: &Key<Self>, iv: &Iv<Self>) -> Self {
+ Self::inner_init(T::Inner::new(key, iv))
+ }
+
+ #[inline]
+ fn new_from_slices(key: &[u8], iv: &[u8]) -> Result<Self, InvalidLength> {
+ T::Inner::new_from_slice(key)
+ .map_err(|_| InvalidLength)
+ .map(Self::inner_init)
+ }
+}
+*/
+
+/// The error type returned when key and/or IV used in the [`KeyInit`],
+/// [`KeyIvInit`], and [`InnerIvInit`] slice-based methods had
+/// an invalid length.
+#[derive(Copy, Clone, Eq, PartialEq, Debug)]
+pub struct InvalidLength;
+
+impl fmt::Display for InvalidLength {
+ fn fmt(&self, f: &mut fmt::Formatter<'_>) -> Result<(), fmt::Error> {
+ f.write_str("Invalid Length")
+ }
+}
+
+#[cfg(feature = "std")]
+impl std::error::Error for InvalidLength {}