summaryrefslogtreecommitdiffstats
path: root/vendor/ctor/Cargo.toml
diff options
context:
space:
mode:
Diffstat (limited to 'vendor/ctor/Cargo.toml')
-rw-r--r--vendor/ctor/Cargo.toml40
1 files changed, 40 insertions, 0 deletions
diff --git a/vendor/ctor/Cargo.toml b/vendor/ctor/Cargo.toml
new file mode 100644
index 000000000..efcd2cffe
--- /dev/null
+++ b/vendor/ctor/Cargo.toml
@@ -0,0 +1,40 @@
+# THIS FILE IS AUTOMATICALLY GENERATED BY CARGO
+#
+# When uploading crates to the registry Cargo will automatically
+# "normalize" Cargo.toml files for maximal compatibility
+# with all versions of Cargo and also rewrite `path` dependencies
+# to registry (e.g., crates.io) dependencies.
+#
+# If you are reading this file be aware that the original Cargo.toml
+# will likely look very different (and much more reasonable).
+# See Cargo.toml.orig for the original contents.
+
+[package]
+edition = "2018"
+name = "ctor"
+version = "0.1.22"
+authors = ["Matt Mastracci <matthew@mastracci.com>"]
+description = "__attribute__((constructor)) for Rust"
+readme = "../README.md"
+license = "Apache-2.0 OR MIT"
+repository = "https://github.com/mmastrac/rust-ctor"
+
+[lib]
+name = "ctor"
+proc-macro = true
+
+[[example]]
+name = "example"
+path = "src/example.rs"
+[dependencies.quote]
+version = "1.0.9"
+
+[dependencies.syn]
+version = "1.0.73"
+features = ["full", "parsing", "printing", "proc-macro"]
+default-features = false
+[dev-dependencies.libc-print]
+version = "0.1.15"
+[badges.travis-ci]
+branch = "master"
+repository = "mmastrac/rust-ctor"