summaryrefslogtreecommitdiffstats
path: root/vendor/dlmalloc/Cargo.toml
diff options
context:
space:
mode:
Diffstat (limited to 'vendor/dlmalloc/Cargo.toml')
-rw-r--r--vendor/dlmalloc/Cargo.toml46
1 files changed, 46 insertions, 0 deletions
diff --git a/vendor/dlmalloc/Cargo.toml b/vendor/dlmalloc/Cargo.toml
new file mode 100644
index 000000000..a8caf460d
--- /dev/null
+++ b/vendor/dlmalloc/Cargo.toml
@@ -0,0 +1,46 @@
+# THIS FILE IS AUTOMATICALLY GENERATED BY CARGO
+#
+# When uploading crates to the registry Cargo will automatically
+# "normalize" Cargo.toml files for maximal compatibility
+# with all versions of Cargo and also rewrite `path` dependencies
+# to registry (e.g., crates.io) dependencies.
+#
+# If you are reading this file be aware that the original Cargo.toml
+# will likely look very different (and much more reasonable).
+# See Cargo.toml.orig for the original contents.
+
+[package]
+name = "dlmalloc"
+version = "0.2.3"
+authors = ["Alex Crichton <alex@alexcrichton.com>"]
+description = "A Rust port of the dlmalloc allocator\n"
+homepage = "https://github.com/alexcrichton/dlmalloc-rs"
+documentation = "https://docs.rs/dlmalloc"
+readme = "README.md"
+license = "MIT/Apache-2.0"
+repository = "https://github.com/alexcrichton/dlmalloc-rs"
+[package.metadata.docs.rs]
+features = ["global"]
+[profile.release]
+debug-assertions = true
+
+[lib]
+doctest = false
+[dependencies.compiler_builtins]
+version = "0.1.0"
+optional = true
+
+[dependencies.core]
+version = "1.0.0"
+optional = true
+package = "rustc-std-workspace-core"
+[dev-dependencies.rand]
+version = "0.3"
+
+[features]
+debug = []
+global = []
+rustc-dep-of-std = ["core", "compiler_builtins/rustc-dep-of-std"]
+[target."cfg(all(unix, not(target_arch = \"wasm32\")))".dependencies.libc]
+version = "0.2"
+default-features = false