summaryrefslogtreecommitdiffstats
path: root/vendor/expect-test
diff options
context:
space:
mode:
Diffstat (limited to 'vendor/expect-test')
-rw-r--r--vendor/expect-test/.cargo-checksum.json2
-rw-r--r--vendor/expect-test/CHANGELOG.md5
-rw-r--r--vendor/expect-test/Cargo.toml2
-rw-r--r--vendor/expect-test/src/lib.rs4
4 files changed, 9 insertions, 4 deletions
diff --git a/vendor/expect-test/.cargo-checksum.json b/vendor/expect-test/.cargo-checksum.json
index 5bd5b89ad..ae0463a30 100644
--- a/vendor/expect-test/.cargo-checksum.json
+++ b/vendor/expect-test/.cargo-checksum.json
@@ -1 +1 @@
-{"files":{"CHANGELOG.md":"f032a324c8763cd7a228779a6402da8c694f8858028084b07b9c2bb6765cac37","Cargo.toml":"9b4ac84b09bbf6f9ee532a9722596450bb8c3508ab2e406639967ff9c97b010a","LICENSE-APACHE":"a60eea817514531668d7e00765731449fe14d059d3249e0bc93b36de45f759f2","LICENSE-MIT":"23f18e03dc49df91622fe2a76176497404e46ced8a715d9d2b67a7446571cca3","README.md":"c3bd17e3bddcdde2d0c62b1c55bf4d483183a47772267c73926bc54a9f92a851","src/lib.rs":"1030dcb8751234682195894d2d20f88351a24ef832ebfc351a3ccea05190a663"},"package":"1d4661aca38d826eb7c72fe128e4238220616de4c0cc00db7bfc38e2e1364dd3"} \ No newline at end of file
+{"files":{"CHANGELOG.md":"0e6133c63cc03604202939e1f20290676d2852d85f85d44cd3d199d23748430e","Cargo.toml":"60d4fd79745fd332eed561dc29690890820f67e681b69a3783ec8ec118f29e99","LICENSE-APACHE":"a60eea817514531668d7e00765731449fe14d059d3249e0bc93b36de45f759f2","LICENSE-MIT":"23f18e03dc49df91622fe2a76176497404e46ced8a715d9d2b67a7446571cca3","README.md":"c3bd17e3bddcdde2d0c62b1c55bf4d483183a47772267c73926bc54a9f92a851","src/lib.rs":"0ec5489511ae8f8740b4add738d44316eddfa9ed6ecdcf722ce509a962c2e8ed"},"package":"30d9eafeadd538e68fb28016364c9732d78e420b9ff8853fa5e4058861e9f8d3"} \ No newline at end of file
diff --git a/vendor/expect-test/CHANGELOG.md b/vendor/expect-test/CHANGELOG.md
index 0d1e5e6ac..afee6bbfb 100644
--- a/vendor/expect-test/CHANGELOG.md
+++ b/vendor/expect-test/CHANGELOG.md
@@ -1,3 +1,7 @@
+# 1.4.1
+
+* Use foreground colors instead of background colors to highlight diffs ([#36])
+
# 1.4.0
* Prefer `CARGO_WORKSPACE_DIR` if set, use heuristic as fallback to find cargo workspace ([#34])
@@ -17,6 +21,7 @@
* No changelog until this point :-(
+[#36]: https://github.com/rust-analyzer/expect-test/pull/36
[#34]: https://github.com/rust-analyzer/expect-test/pull/34
[#31]: https://github.com/rust-analyzer/expect-test/pull/31
[#27]: https://github.com/rust-analyzer/expect-test/pull/27
diff --git a/vendor/expect-test/Cargo.toml b/vendor/expect-test/Cargo.toml
index c02e4ddea..1db80473d 100644
--- a/vendor/expect-test/Cargo.toml
+++ b/vendor/expect-test/Cargo.toml
@@ -12,7 +12,7 @@
[package]
edition = "2018"
name = "expect-test"
-version = "1.4.0"
+version = "1.4.1"
authors = ["rust-analyzer developers"]
exclude = [
"./github",
diff --git a/vendor/expect-test/src/lib.rs b/vendor/expect-test/src/lib.rs
index 83fcf35bf..a82b03195 100644
--- a/vendor/expect-test/src/lib.rs
+++ b/vendor/expect-test/src/lib.rs
@@ -719,8 +719,8 @@ fn format_chunks(chunks: Vec<dissimilar::Chunk>) -> String {
for chunk in chunks {
let formatted = match chunk {
dissimilar::Chunk::Equal(text) => text.into(),
- dissimilar::Chunk::Delete(text) => format!("\x1b[41m{}\x1b[0m", text),
- dissimilar::Chunk::Insert(text) => format!("\x1b[42m{}\x1b[0m", text),
+ dissimilar::Chunk::Delete(text) => format!("\x1b[4m\x1b[31m{}\x1b[0m", text),
+ dissimilar::Chunk::Insert(text) => format!("\x1b[4m\x1b[32m{}\x1b[0m", text),
};
buf.push_str(&formatted);
}