summaryrefslogtreecommitdiffstats
path: root/vendor/ff/Cargo.toml
diff options
context:
space:
mode:
Diffstat (limited to 'vendor/ff/Cargo.toml')
-rw-r--r--vendor/ff/Cargo.toml64
1 files changed, 64 insertions, 0 deletions
diff --git a/vendor/ff/Cargo.toml b/vendor/ff/Cargo.toml
new file mode 100644
index 000000000..49a974693
--- /dev/null
+++ b/vendor/ff/Cargo.toml
@@ -0,0 +1,64 @@
+# THIS FILE IS AUTOMATICALLY GENERATED BY CARGO
+#
+# When uploading crates to the registry Cargo will automatically
+# "normalize" Cargo.toml files for maximal compatibility
+# with all versions of Cargo and also rewrite `path` dependencies
+# to registry (e.g., crates.io) dependencies.
+#
+# If you are reading this file be aware that the original Cargo.toml
+# will likely look very different (and much more reasonable).
+# See Cargo.toml.orig for the original contents.
+
+[package]
+edition = "2021"
+name = "ff"
+version = "0.12.1"
+authors = ["Sean Bowe <ewillbefull@gmail.com>", "Jack Grigg <thestr4d@gmail.com>"]
+description = "Library for building and interfacing with finite fields"
+homepage = "https://github.com/zkcrypto/ff"
+documentation = "https://docs.rs/ff/"
+readme = "README.md"
+license = "MIT/Apache-2.0"
+repository = "https://github.com/zkcrypto/ff"
+resolver = "2"
+[package.metadata.docs.rs]
+all-features = true
+rustdoc-args = ["--cfg", "docsrs"]
+
+[[test]]
+name = "derive"
+required-features = ["derive"]
+[dependencies.bitvec]
+version = "1"
+optional = true
+default-features = false
+
+[dependencies.byteorder]
+version = "1"
+optional = true
+default-features = false
+
+[dependencies.ff_derive]
+version = "0.12.1"
+optional = true
+
+[dependencies.rand_core]
+version = "0.6"
+default-features = false
+
+[dependencies.subtle]
+version = "2.2.1"
+features = ["i128"]
+default-features = false
+[dev-dependencies.rand]
+version = "0.8"
+
+[features]
+alloc = []
+bits = ["bitvec"]
+default = ["bits", "std"]
+derive = ["byteorder", "ff_derive"]
+derive_bits = ["bits", "ff_derive/bits"]
+std = ["alloc"]
+[badges.maintenance]
+status = "actively-developed"