summaryrefslogtreecommitdiffstats
path: root/vendor/flate2/Cargo.toml
diff options
context:
space:
mode:
Diffstat (limited to 'vendor/flate2/Cargo.toml')
-rw-r--r--vendor/flate2/Cargo.toml94
1 files changed, 94 insertions, 0 deletions
diff --git a/vendor/flate2/Cargo.toml b/vendor/flate2/Cargo.toml
new file mode 100644
index 000000000..23b8b80d0
--- /dev/null
+++ b/vendor/flate2/Cargo.toml
@@ -0,0 +1,94 @@
+# THIS FILE IS AUTOMATICALLY GENERATED BY CARGO
+#
+# When uploading crates to the registry Cargo will automatically
+# "normalize" Cargo.toml files for maximal compatibility
+# with all versions of Cargo and also rewrite `path` dependencies
+# to registry (e.g., crates.io) dependencies.
+#
+# If you are reading this file be aware that the original Cargo.toml
+# will likely look very different (and much more reasonable).
+# See Cargo.toml.orig for the original contents.
+
+[package]
+edition = "2018"
+name = "flate2"
+version = "1.0.24"
+authors = [
+ "Alex Crichton <alex@alexcrichton.com>",
+ "Josh Triplett <josh@joshtriplett.org>",
+]
+description = """
+DEFLATE compression and decompression exposed as Read/BufRead/Write streams.
+Supports miniz_oxide and multiple zlib implementations. Supports zlib, gzip,
+and raw deflate streams.
+"""
+homepage = "https://github.com/rust-lang/flate2-rs"
+documentation = "https://docs.rs/flate2"
+readme = "README.md"
+keywords = [
+ "gzip",
+ "deflate",
+ "zlib",
+ "zlib-ng",
+ "encoding",
+]
+categories = [
+ "compression",
+ "api-bindings",
+]
+license = "MIT OR Apache-2.0"
+repository = "https://github.com/rust-lang/flate2-rs"
+
+[dependencies.cloudflare-zlib-sys]
+version = "0.3.0"
+optional = true
+
+[dependencies.crc32fast]
+version = "1.2.0"
+
+[dependencies.libz-ng-sys]
+version = "1.1.8"
+optional = true
+
+[dependencies.libz-sys]
+version = "1.1.8"
+optional = true
+default-features = false
+
+[dependencies.miniz_oxide]
+version = "0.5.0"
+optional = true
+default-features = false
+
+[dev-dependencies.quickcheck]
+version = "1.0"
+default-features = false
+
+[dev-dependencies.rand]
+version = "0.8"
+
+[features]
+any_zlib = []
+cloudflare_zlib = [
+ "any_zlib",
+ "cloudflare-zlib-sys",
+]
+default = ["rust_backend"]
+miniz-sys = ["rust_backend"]
+rust_backend = ["miniz_oxide"]
+zlib = [
+ "any_zlib",
+ "libz-sys",
+]
+zlib-ng = [
+ "any_zlib",
+ "libz-ng-sys",
+]
+zlib-ng-compat = [
+ "zlib",
+ "libz-sys/zlib-ng",
+]
+
+[target."cfg(all(target_arch = \"wasm32\", not(target_os = \"emscripten\")))".dependencies.miniz_oxide]
+version = "0.5.0"
+default-features = false