summaryrefslogtreecommitdiffstats
path: root/vendor/fst/Cargo.toml
diff options
context:
space:
mode:
Diffstat (limited to 'vendor/fst/Cargo.toml')
-rw-r--r--vendor/fst/Cargo.toml53
1 files changed, 53 insertions, 0 deletions
diff --git a/vendor/fst/Cargo.toml b/vendor/fst/Cargo.toml
new file mode 100644
index 000000000..986e92dc5
--- /dev/null
+++ b/vendor/fst/Cargo.toml
@@ -0,0 +1,53 @@
+# THIS FILE IS AUTOMATICALLY GENERATED BY CARGO
+#
+# When uploading crates to the registry Cargo will automatically
+# "normalize" Cargo.toml files for maximal compatibility
+# with all versions of Cargo and also rewrite `path` dependencies
+# to registry (e.g., crates.io) dependencies
+#
+# If you believe there's an error in this file please file an
+# issue against the rust-lang/cargo repository. If you're
+# editing this file be aware that the upstream Cargo.toml
+# will likely look very different (and much more reasonable)
+
+[package]
+edition = "2018"
+name = "fst"
+version = "0.4.7"
+authors = ["Andrew Gallant <jamslam@gmail.com>"]
+description = "Use finite state transducers to compactly represents sets or maps of many\nstrings (> 1 billion is possible).\n"
+homepage = "https://github.com/BurntSushi/fst"
+documentation = "https://docs.rs/fst"
+readme = "README.md"
+keywords = ["search", "information", "retrieval", "dictionary", "map"]
+license = "Unlicense/MIT"
+repository = "https://github.com/BurntSushi/fst"
+[package.metadata.docs.rs]
+features = ["levenshtein"]
+[profile.bench]
+debug = true
+
+[profile.release]
+debug = true
+[dependencies.utf8-ranges]
+version = "1.0.4"
+optional = true
+[dev-dependencies.doc-comment]
+version = "0.3.1"
+
+[dev-dependencies.fnv]
+version = "1.0.6"
+
+[dev-dependencies.memmap]
+version = "0.7"
+
+[dev-dependencies.quickcheck]
+version = "0.9.2"
+default-features = false
+
+[dev-dependencies.rand]
+version = "0.7.3"
+
+[features]
+default = []
+levenshtein = ["utf8-ranges"]