summaryrefslogtreecommitdiffstats
path: root/vendor/gimli-0.25.0/Cargo.toml
diff options
context:
space:
mode:
Diffstat (limited to '')
-rw-r--r--vendor/gimli-0.25.0/Cargo.toml114
1 files changed, 114 insertions, 0 deletions
diff --git a/vendor/gimli-0.25.0/Cargo.toml b/vendor/gimli-0.25.0/Cargo.toml
new file mode 100644
index 000000000..82daa1668
--- /dev/null
+++ b/vendor/gimli-0.25.0/Cargo.toml
@@ -0,0 +1,114 @@
+# THIS FILE IS AUTOMATICALLY GENERATED BY CARGO
+#
+# When uploading crates to the registry Cargo will automatically
+# "normalize" Cargo.toml files for maximal compatibility
+# with all versions of Cargo and also rewrite `path` dependencies
+# to registry (e.g., crates.io) dependencies
+#
+# If you believe there's an error in this file please file an
+# issue against the rust-lang/cargo repository. If you're
+# editing this file be aware that the upstream Cargo.toml
+# will likely look very different (and much more reasonable)
+
+[package]
+edition = "2018"
+name = "gimli"
+version = "0.25.0"
+exclude = ["/ci/*", "/releases/*", "/.travis.yml"]
+description = "A library for reading and writing the DWARF debugging format."
+documentation = "https://docs.rs/gimli"
+readme = "./README.md"
+keywords = ["DWARF", "debug", "ELF", "eh_frame"]
+categories = ["development-tools::debugging", "development-tools::profiling", "parser-implementations"]
+license = "Apache-2.0/MIT"
+repository = "https://github.com/gimli-rs/gimli"
+[profile.bench]
+codegen-units = 1
+debug = true
+split-debuginfo = "packed"
+
+[profile.test]
+split-debuginfo = "packed"
+
+[[example]]
+name = "simple"
+required-features = ["read"]
+
+[[example]]
+name = "simple_line"
+required-features = ["read"]
+
+[[example]]
+name = "dwarfdump"
+required-features = ["read", "std"]
+
+[[example]]
+name = "dwarf-validate"
+required-features = ["read", "std"]
+[dependencies.alloc]
+version = "1.0.0"
+optional = true
+package = "rustc-std-workspace-alloc"
+
+[dependencies.compiler_builtins]
+version = "0.1.2"
+optional = true
+
+[dependencies.core]
+version = "1.0.0"
+optional = true
+package = "rustc-std-workspace-core"
+
+[dependencies.fallible-iterator]
+version = "0.2.0"
+optional = true
+default-features = false
+
+[dependencies.indexmap]
+version = "1.0.2"
+optional = true
+
+[dependencies.stable_deref_trait]
+version = "1.1.0"
+optional = true
+default-features = false
+[dev-dependencies.crossbeam]
+version = "0.8"
+
+[dev-dependencies.getopts]
+version = "0.2"
+
+[dev-dependencies.memmap]
+version = "0.7"
+
+[dev-dependencies.num_cpus]
+version = "1"
+
+[dev-dependencies.object]
+version = "0.26"
+features = ["wasm"]
+
+[dev-dependencies.rayon]
+version = "1.0"
+
+[dev-dependencies.regex]
+version = "1"
+
+[dev-dependencies.test-assembler]
+version = "0.1.3"
+
+[dev-dependencies.typed-arena]
+version = "2"
+
+[features]
+default = ["read", "write", "std", "fallible-iterator", "endian-reader"]
+endian-reader = ["stable_deref_trait"]
+read = []
+rustc-dep-of-std = ["core", "alloc", "compiler_builtins"]
+std = ["fallible-iterator/std", "stable_deref_trait/std"]
+write = ["indexmap"]
+[badges.coveralls]
+repository = "gimli-rs/gimli"
+
+[badges.travis-ci]
+repository = "gimli-rs/gimli"