summaryrefslogtreecommitdiffstats
path: root/vendor/gimli/Cargo.toml
diff options
context:
space:
mode:
Diffstat (limited to 'vendor/gimli/Cargo.toml')
-rw-r--r--vendor/gimli/Cargo.toml79
1 files changed, 55 insertions, 24 deletions
diff --git a/vendor/gimli/Cargo.toml b/vendor/gimli/Cargo.toml
index d5f283c80..f36ccd936 100644
--- a/vendor/gimli/Cargo.toml
+++ b/vendor/gimli/Cargo.toml
@@ -3,25 +3,37 @@
# When uploading crates to the registry Cargo will automatically
# "normalize" Cargo.toml files for maximal compatibility
# with all versions of Cargo and also rewrite `path` dependencies
-# to registry (e.g., crates.io) dependencies
+# to registry (e.g., crates.io) dependencies.
#
-# If you believe there's an error in this file please file an
-# issue against the rust-lang/cargo repository. If you're
-# editing this file be aware that the upstream Cargo.toml
-# will likely look very different (and much more reasonable)
+# If you are reading this file be aware that the original Cargo.toml
+# will likely look very different (and much more reasonable).
+# See Cargo.toml.orig for the original contents.
[package]
edition = "2018"
name = "gimli"
-version = "0.26.1"
-exclude = ["/ci/*", "/releases/*", "/.github"]
+version = "0.26.2"
+exclude = [
+ "/releases/*",
+ "/.github",
+]
description = "A library for reading and writing the DWARF debugging format."
documentation = "https://docs.rs/gimli"
readme = "./README.md"
-keywords = ["DWARF", "debug", "ELF", "eh_frame"]
-categories = ["development-tools::debugging", "development-tools::profiling", "parser-implementations"]
-license = "Apache-2.0/MIT"
+keywords = [
+ "DWARF",
+ "debug",
+ "ELF",
+ "eh_frame",
+]
+categories = [
+ "development-tools::debugging",
+ "development-tools::profiling",
+ "parser-implementations",
+]
+license = "MIT OR Apache-2.0"
repository = "https://github.com/gimli-rs/gimli"
+
[profile.bench]
codegen-units = 1
debug = true
@@ -40,11 +52,18 @@ required-features = ["read"]
[[example]]
name = "dwarfdump"
-required-features = ["read", "std"]
+required-features = [
+ "read",
+ "std",
+]
[[example]]
name = "dwarf-validate"
-required-features = ["read", "std"]
+required-features = [
+ "read",
+ "std",
+]
+
[dependencies.alloc]
version = "1.0.0"
optional = true
@@ -72,20 +91,21 @@ optional = true
version = "1.1.0"
optional = true
default-features = false
+
[dev-dependencies.crossbeam]
version = "0.8"
[dev-dependencies.getopts]
version = "0.2"
-[dev-dependencies.memmap]
-version = "0.7"
+[dev-dependencies.memmap2]
+version = "0.5.5"
[dev-dependencies.num_cpus]
version = "1"
[dev-dependencies.object]
-version = "0.27.1"
+version = "0.29.0"
features = ["wasm"]
[dev-dependencies.rayon]
@@ -101,15 +121,26 @@ version = "0.1.3"
version = "2"
[features]
-default = ["read", "write", "std", "fallible-iterator", "endian-reader"]
-endian-reader = ["read", "stable_deref_trait"]
+default = [
+ "read",
+ "write",
+ "std",
+ "fallible-iterator",
+ "endian-reader",
+]
+endian-reader = [
+ "read",
+ "stable_deref_trait",
+]
read = ["read-core"]
read-core = []
-rustc-dep-of-std = ["core", "alloc", "compiler_builtins"]
-std = ["fallible-iterator/std", "stable_deref_trait/std"]
+rustc-dep-of-std = [
+ "core",
+ "alloc",
+ "compiler_builtins",
+]
+std = [
+ "fallible-iterator/std",
+ "stable_deref_trait/std",
+]
write = ["indexmap"]
-[badges.coveralls]
-repository = "gimli-rs/gimli"
-
-[badges.travis-ci]
-repository = "gimli-rs/gimli"