summaryrefslogtreecommitdiffstats
path: root/vendor/gix-discover/Cargo.toml
diff options
context:
space:
mode:
Diffstat (limited to 'vendor/gix-discover/Cargo.toml')
-rw-r--r--vendor/gix-discover/Cargo.toml65
1 files changed, 65 insertions, 0 deletions
diff --git a/vendor/gix-discover/Cargo.toml b/vendor/gix-discover/Cargo.toml
new file mode 100644
index 000000000..ad10f7678
--- /dev/null
+++ b/vendor/gix-discover/Cargo.toml
@@ -0,0 +1,65 @@
+# THIS FILE IS AUTOMATICALLY GENERATED BY CARGO
+#
+# When uploading crates to the registry Cargo will automatically
+# "normalize" Cargo.toml files for maximal compatibility
+# with all versions of Cargo and also rewrite `path` dependencies
+# to registry (e.g., crates.io) dependencies.
+#
+# If you are reading this file be aware that the original Cargo.toml
+# will likely look very different (and much more reasonable).
+# See Cargo.toml.orig for the original contents.
+
+[package]
+edition = "2021"
+rust-version = "1.64"
+name = "gix-discover"
+version = "0.15.0"
+authors = ["Sebastian Thiel <sebastian.thiel@icloud.com>"]
+include = [
+ "src/**/*",
+ "CHANGELOG.md",
+]
+description = "Discover git repositories and check if a directory is a git repository"
+license = "MIT/Apache-2.0"
+repository = "https://github.com/Byron/gitoxide"
+
+[lib]
+doctest = false
+
+[dependencies.bstr]
+version = "1.3.0"
+features = [
+ "std",
+ "unicode",
+]
+default-features = false
+
+[dependencies.gix-hash]
+version = "^0.10.3"
+
+[dependencies.gix-path]
+version = "^0.7.2"
+
+[dependencies.gix-ref]
+version = "^0.26.0"
+
+[dependencies.gix-sec]
+version = "^0.6.2"
+
+[dependencies.thiserror]
+version = "1.0.26"
+
+[dev-dependencies.is_ci]
+version = "1.1.1"
+
+[dev-dependencies.serial_test]
+version = "1.0.0"
+
+[target."cfg(any(unix, windows))".dev-dependencies.tempfile]
+version = "3.2.0"
+
+[target."cfg(target_os = \"macos\")".dev-dependencies.defer]
+version = "0.1.0"
+
+[target."cfg(windows)".dependencies.dunce]
+version = "1.0.3"