summaryrefslogtreecommitdiffstats
path: root/vendor/gix-macros/Cargo.toml
diff options
context:
space:
mode:
Diffstat (limited to 'vendor/gix-macros/Cargo.toml')
-rw-r--r--vendor/gix-macros/Cargo.toml48
1 files changed, 48 insertions, 0 deletions
diff --git a/vendor/gix-macros/Cargo.toml b/vendor/gix-macros/Cargo.toml
new file mode 100644
index 000000000..4cefc9fd9
--- /dev/null
+++ b/vendor/gix-macros/Cargo.toml
@@ -0,0 +1,48 @@
+# THIS FILE IS AUTOMATICALLY GENERATED BY CARGO
+#
+# When uploading crates to the registry Cargo will automatically
+# "normalize" Cargo.toml files for maximal compatibility
+# with all versions of Cargo and also rewrite `path` dependencies
+# to registry (e.g., crates.io) dependencies.
+#
+# If you are reading this file be aware that the original Cargo.toml
+# will likely look very different (and much more reasonable).
+# See Cargo.toml.orig for the original contents.
+
+[package]
+edition = "2021"
+rust-version = "1.65"
+name = "gix-macros"
+version = "0.1.0"
+authors = [
+ "Jiahao XU <Jiahao_XU@outlook.com>",
+ "Andre Bogus <bogusandre@gmail.com>",
+ "Sebastian Thiel <sebastian.thiel@icloud.com>",
+]
+include = [
+ "src/**/*",
+ "LICENSE-*",
+ "CHANGELOG.md",
+]
+description = "Proc-macro utilities for gix"
+license = "MIT OR Apache-2.0"
+repository = "https://github.com/Byron/gitoxide"
+
+[lib]
+proc_macro = true
+
+[dependencies.proc-macro2]
+version = "1.0"
+
+[dependencies.quote]
+version = "1.0"
+
+[dependencies.syn]
+version = "2.0"
+features = [
+ "full",
+ "fold",
+]
+
+[dev-dependencies.trybuild]
+version = "1.0"