summaryrefslogtreecommitdiffstats
path: root/vendor/gix-tempfile/Cargo.toml
diff options
context:
space:
mode:
Diffstat (limited to 'vendor/gix-tempfile/Cargo.toml')
-rw-r--r--vendor/gix-tempfile/Cargo.toml97
1 files changed, 97 insertions, 0 deletions
diff --git a/vendor/gix-tempfile/Cargo.toml b/vendor/gix-tempfile/Cargo.toml
new file mode 100644
index 000000000..7dba7fd20
--- /dev/null
+++ b/vendor/gix-tempfile/Cargo.toml
@@ -0,0 +1,97 @@
+# THIS FILE IS AUTOMATICALLY GENERATED BY CARGO
+#
+# When uploading crates to the registry Cargo will automatically
+# "normalize" Cargo.toml files for maximal compatibility
+# with all versions of Cargo and also rewrite `path` dependencies
+# to registry (e.g., crates.io) dependencies.
+#
+# If you are reading this file be aware that the original Cargo.toml
+# will likely look very different (and much more reasonable).
+# See Cargo.toml.orig for the original contents.
+
+[package]
+edition = "2021"
+rust-version = "1.64"
+name = "gix-tempfile"
+version = "4.1.1"
+authors = ["Sebastian Thiel <sebastian.thiel@icloud.com>"]
+include = [
+ "src/**/*",
+ "LICENSE-*",
+ "README.md",
+ "CHANGELOG.md",
+]
+description = "A tempfile implementation with a global registry to assure cleanup"
+readme = "README.md"
+license = "MIT/Apache-2.0"
+repository = "https://github.com/Byron/gitoxide"
+
+[package.metadata.docs.rs]
+all-features = true
+features = ["document-features"]
+rustdoc-args = [
+ "--cfg",
+ "docsrs",
+]
+
+[lib]
+test = true
+doctest = false
+
+[[example]]
+name = "delete-tempfiles-on-sigterm"
+path = "examples/delete-tempfiles-on-sigterm.rs"
+required-features = ["signals"]
+
+[[example]]
+name = "delete-tempfiles-on-sigterm-interactive"
+path = "examples/delete-tempfiles-on-sigterm-interactive.rs"
+required-features = ["signals"]
+
+[[example]]
+name = "try-deadlock-on-cleanup"
+path = "examples/try-deadlock-on-cleanup.rs"
+required-features = ["signals"]
+
+[dependencies.dashmap]
+version = "5.1.0"
+optional = true
+
+[dependencies.document-features]
+version = "0.2.0"
+optional = true
+
+[dependencies.once_cell]
+version = "1.8.0"
+features = [
+ "race",
+ "std",
+]
+default-features = false
+
+[dependencies.parking_lot]
+version = "0.12.1"
+
+[dependencies.signal-hook]
+version = "0.3.9"
+optional = true
+default-features = false
+
+[dependencies.signal-hook-registry]
+version = "1.4.0"
+optional = true
+
+[dependencies.tempfile]
+version = "~3.3.0"
+
+[features]
+default = ["hp-hashmap"]
+hp-hashmap = ["dep:dashmap"]
+signals = [
+ "dep:signal-hook",
+ "dep:signal-hook-registry",
+]
+
+[target."cfg(not(windows))".dependencies.libc]
+version = "0.2.98"
+default-features = false