summaryrefslogtreecommitdiffstats
path: root/vendor/handlebars/Cargo.toml
diff options
context:
space:
mode:
Diffstat (limited to 'vendor/handlebars/Cargo.toml')
-rw-r--r--vendor/handlebars/Cargo.toml98
1 files changed, 98 insertions, 0 deletions
diff --git a/vendor/handlebars/Cargo.toml b/vendor/handlebars/Cargo.toml
new file mode 100644
index 000000000..f46e0bd13
--- /dev/null
+++ b/vendor/handlebars/Cargo.toml
@@ -0,0 +1,98 @@
+# THIS FILE IS AUTOMATICALLY GENERATED BY CARGO
+#
+# When uploading crates to the registry Cargo will automatically
+# "normalize" Cargo.toml files for maximal compatibility
+# with all versions of Cargo and also rewrite `path` dependencies
+# to registry (e.g., crates.io) dependencies
+#
+# If you believe there's an error in this file please file an
+# issue against the rust-lang/cargo repository. If you're
+# editing this file be aware that the upstream Cargo.toml
+# will likely look very different (and much more reasonable)
+
+[package]
+edition = "2018"
+name = "handlebars"
+version = "4.1.0"
+authors = ["Ning Sun <sunng@pm.me>"]
+description = "Handlebars templating implemented in Rust."
+homepage = "https://github.com/sunng87/handlebars-rust"
+documentation = "https://docs.rs/crate/handlebars/"
+readme = "README.md"
+keywords = ["handlebars", "templating", "web"]
+categories = ["template-engine", "web-programming"]
+license = "MIT"
+repository = "https://github.com/sunng87/handlebars-rust"
+[package.metadata.docs.rs]
+features = ["dir_source", "script_helper"]
+rustdoc-args = ["--cfg", "docsrs"]
+
+[lib]
+name = "handlebars"
+path = "src/lib.rs"
+
+[[bin]]
+name = "handlebars-cli"
+path = "src/cli.rs"
+
+[[bench]]
+name = "bench"
+harness = false
+[dependencies.log]
+version = "0.4.0"
+
+[dependencies.pest]
+version = "2.1.0"
+
+[dependencies.pest_derive]
+version = "2.1.0"
+
+[dependencies.quick-error]
+version = "2.0"
+
+[dependencies.rhai]
+version = "0.20"
+features = ["sync", "serde"]
+optional = true
+
+[dependencies.serde]
+version = "1.0.0"
+
+[dependencies.serde_json]
+version = "1.0.39"
+
+[dependencies.walkdir]
+version = "2.2.3"
+optional = true
+[dev-dependencies.criterion]
+version = "0.3"
+
+[dev-dependencies.env_logger]
+version = "0.8"
+
+[dev-dependencies.maplit]
+version = "1.0.0"
+
+[dev-dependencies.serde_derive]
+version = "1.0.75"
+
+[dev-dependencies.tempfile]
+version = "3.0.0"
+
+[dev-dependencies.tokio]
+version = "1"
+features = ["macros", "rt-multi-thread"]
+
+[dev-dependencies.warp]
+version = "0.3"
+
+[features]
+default = []
+dir_source = ["walkdir"]
+no_logging = []
+script_helper = ["rhai"]
+[target."cfg(unix)".dev-dependencies.pprof]
+version = "0.3.13"
+features = ["flamegraph", "protobuf"]
+[badges.maintenance]
+status = "actively-developed"