summaryrefslogtreecommitdiffstats
path: root/vendor/hashbrown-0.12.3/Cargo.toml
diff options
context:
space:
mode:
Diffstat (limited to 'vendor/hashbrown-0.12.3/Cargo.toml')
-rw-r--r--vendor/hashbrown-0.12.3/Cargo.toml113
1 files changed, 113 insertions, 0 deletions
diff --git a/vendor/hashbrown-0.12.3/Cargo.toml b/vendor/hashbrown-0.12.3/Cargo.toml
new file mode 100644
index 000000000..fb130d24d
--- /dev/null
+++ b/vendor/hashbrown-0.12.3/Cargo.toml
@@ -0,0 +1,113 @@
+# THIS FILE IS AUTOMATICALLY GENERATED BY CARGO
+#
+# When uploading crates to the registry Cargo will automatically
+# "normalize" Cargo.toml files for maximal compatibility
+# with all versions of Cargo and also rewrite `path` dependencies
+# to registry (e.g., crates.io) dependencies.
+#
+# If you are reading this file be aware that the original Cargo.toml
+# will likely look very different (and much more reasonable).
+# See Cargo.toml.orig for the original contents.
+
+[package]
+edition = "2021"
+rust-version = "1.56.0"
+name = "hashbrown"
+version = "0.12.3"
+authors = ["Amanieu d'Antras <amanieu@gmail.com>"]
+exclude = [
+ ".github",
+ "/ci/*",
+]
+description = "A Rust port of Google's SwissTable hash map"
+readme = "README.md"
+keywords = [
+ "hash",
+ "no_std",
+ "hashmap",
+ "swisstable",
+]
+categories = [
+ "data-structures",
+ "no-std",
+]
+license = "MIT OR Apache-2.0"
+repository = "https://github.com/rust-lang/hashbrown"
+resolver = "2"
+
+[package.metadata.docs.rs]
+features = [
+ "nightly",
+ "rayon",
+ "serde",
+ "raw",
+]
+
+[dependencies.ahash]
+version = "0.7.0"
+optional = true
+default-features = false
+
+[dependencies.alloc]
+version = "1.0.0"
+optional = true
+package = "rustc-std-workspace-alloc"
+
+[dependencies.bumpalo]
+version = "3.5.0"
+optional = true
+
+[dependencies.compiler_builtins]
+version = "0.1.2"
+optional = true
+
+[dependencies.core]
+version = "1.0.0"
+optional = true
+package = "rustc-std-workspace-core"
+
+[dependencies.rayon]
+version = "1.0"
+optional = true
+
+[dependencies.serde]
+version = "1.0.25"
+optional = true
+default-features = false
+
+[dev-dependencies.doc-comment]
+version = "0.3.1"
+
+[dev-dependencies.fnv]
+version = "1.0.7"
+
+[dev-dependencies.lazy_static]
+version = "1.4"
+
+[dev-dependencies.rand]
+version = "0.8.3"
+features = ["small_rng"]
+
+[dev-dependencies.rayon]
+version = "1.0"
+
+[dev-dependencies.serde_test]
+version = "1.0"
+
+[features]
+ahash-compile-time-rng = ["ahash/compile-time-rng"]
+default = [
+ "ahash",
+ "inline-more",
+]
+inline-more = []
+nightly = []
+raw = []
+rustc-dep-of-std = [
+ "nightly",
+ "core",
+ "compiler_builtins",
+ "alloc",
+ "rustc-internal-api",
+]
+rustc-internal-api = []