summaryrefslogtreecommitdiffstats
path: root/vendor/hermit-abi-0.2.6/Cargo.toml
diff options
context:
space:
mode:
Diffstat (limited to 'vendor/hermit-abi-0.2.6/Cargo.toml')
-rw-r--r--vendor/hermit-abi-0.2.6/Cargo.toml62
1 files changed, 62 insertions, 0 deletions
diff --git a/vendor/hermit-abi-0.2.6/Cargo.toml b/vendor/hermit-abi-0.2.6/Cargo.toml
new file mode 100644
index 000000000..314aa6ad4
--- /dev/null
+++ b/vendor/hermit-abi-0.2.6/Cargo.toml
@@ -0,0 +1,62 @@
+# THIS FILE IS AUTOMATICALLY GENERATED BY CARGO
+#
+# When uploading crates to the registry Cargo will automatically
+# "normalize" Cargo.toml files for maximal compatibility
+# with all versions of Cargo and also rewrite `path` dependencies
+# to registry (e.g., crates.io) dependencies.
+#
+# If you are reading this file be aware that the original Cargo.toml
+# will likely look very different (and much more reasonable).
+# See Cargo.toml.orig for the original contents.
+
+[package]
+edition = "2021"
+name = "hermit-abi"
+version = "0.2.6"
+authors = ["Stefan Lankes"]
+description = """
+hermit-abi is small interface to call functions from the unikernel RustyHermit.
+It is used to build the target `x86_64-unknown-hermit`.
+"""
+documentation = "https://hermitcore.github.io/rusty-hermit/hermit_abi"
+readme = "README.md"
+keywords = [
+ "unikernel",
+ "libos",
+]
+categories = ["os"]
+license = "MIT/Apache-2.0"
+repository = "https://github.com/hermitcore/rusty-hermit"
+resolver = "1"
+
+[package.metadata.docs.rs]
+features = ["docs"]
+default-target = "x86_64-unknown-hermit"
+
+[dependencies.alloc]
+version = "1.0.0"
+optional = true
+package = "rustc-std-workspace-alloc"
+
+[dependencies.compiler_builtins]
+version = "0.1"
+optional = true
+
+[dependencies.core]
+version = "1.0.0"
+optional = true
+package = "rustc-std-workspace-core"
+
+[dependencies.libc]
+version = "0.2"
+default-features = false
+
+[features]
+default = []
+docs = []
+rustc-dep-of-std = [
+ "core",
+ "alloc",
+ "compiler_builtins/rustc-dep-of-std",
+ "libc/rustc-dep-of-std",
+]