summaryrefslogtreecommitdiffstats
path: root/vendor/hermit-abi/Cargo.toml
diff options
context:
space:
mode:
Diffstat (limited to '')
-rw-r--r--vendor/hermit-abi/Cargo.toml31
1 files changed, 25 insertions, 6 deletions
diff --git a/vendor/hermit-abi/Cargo.toml b/vendor/hermit-abi/Cargo.toml
index 81b32c9bf..314aa6ad4 100644
--- a/vendor/hermit-abi/Cargo.toml
+++ b/vendor/hermit-abi/Cargo.toml
@@ -12,18 +12,32 @@
[package]
edition = "2021"
name = "hermit-abi"
-version = "0.2.0"
+version = "0.2.6"
authors = ["Stefan Lankes"]
-description = "hermit-abi is small interface to call functions from the unikernel RustyHermit.\nIt is used to build the target `x86_64-unknown-hermit`.\n"
+description = """
+hermit-abi is small interface to call functions from the unikernel RustyHermit.
+It is used to build the target `x86_64-unknown-hermit`.
+"""
documentation = "https://hermitcore.github.io/rusty-hermit/hermit_abi"
readme = "README.md"
-keywords = ["unikernel", "libos"]
+keywords = [
+ "unikernel",
+ "libos",
+]
categories = ["os"]
license = "MIT/Apache-2.0"
repository = "https://github.com/hermitcore/rusty-hermit"
+resolver = "1"
+
[package.metadata.docs.rs]
-default-target = "x86_64-unknown-hermit"
features = ["docs"]
+default-target = "x86_64-unknown-hermit"
+
+[dependencies.alloc]
+version = "1.0.0"
+optional = true
+package = "rustc-std-workspace-alloc"
+
[dependencies.compiler_builtins]
version = "0.1"
optional = true
@@ -34,10 +48,15 @@ optional = true
package = "rustc-std-workspace-core"
[dependencies.libc]
-version = "0.2.51"
+version = "0.2"
default-features = false
[features]
default = []
docs = []
-rustc-dep-of-std = ["core", "compiler_builtins/rustc-dep-of-std", "libc/rustc-dep-of-std"]
+rustc-dep-of-std = [
+ "core",
+ "alloc",
+ "compiler_builtins/rustc-dep-of-std",
+ "libc/rustc-dep-of-std",
+]