summaryrefslogtreecommitdiffstats
path: root/vendor/hex/Cargo.toml
diff options
context:
space:
mode:
Diffstat (limited to 'vendor/hex/Cargo.toml')
-rw-r--r--vendor/hex/Cargo.toml63
1 files changed, 63 insertions, 0 deletions
diff --git a/vendor/hex/Cargo.toml b/vendor/hex/Cargo.toml
new file mode 100644
index 000000000..fab04a8a4
--- /dev/null
+++ b/vendor/hex/Cargo.toml
@@ -0,0 +1,63 @@
+# THIS FILE IS AUTOMATICALLY GENERATED BY CARGO
+#
+# When uploading crates to the registry Cargo will automatically
+# "normalize" Cargo.toml files for maximal compatibility
+# with all versions of Cargo and also rewrite `path` dependencies
+# to registry (e.g., crates.io) dependencies
+#
+# If you believe there's an error in this file please file an
+# issue against the rust-lang/cargo repository. If you're
+# editing this file be aware that the upstream Cargo.toml
+# will likely look very different (and much more reasonable)
+
+[package]
+edition = "2018"
+name = "hex"
+version = "0.4.3"
+authors = ["KokaKiwi <kokakiwi@kokakiwi.net>"]
+description = "Encoding and decoding data into/from hexadecimal representation."
+documentation = "https://docs.rs/hex/"
+readme = "README.md"
+keywords = ["no_std", "hex"]
+categories = ["encoding", "no-std"]
+license = "MIT OR Apache-2.0"
+repository = "https://github.com/KokaKiwi/rust-hex"
+[package.metadata.docs.rs]
+all-features = true
+rustdoc-args = ["--cfg", "docsrs"]
+
+[[bench]]
+name = "hex"
+harness = false
+[dependencies.serde]
+version = "1.0"
+optional = true
+default-features = false
+[dev-dependencies.criterion]
+version = "0.3"
+
+[dev-dependencies.faster-hex]
+version = "0.5"
+
+[dev-dependencies.pretty_assertions]
+version = "0.6"
+
+[dev-dependencies.rustc-hex]
+version = "2.1"
+
+[dev-dependencies.serde]
+version = "1.0"
+features = ["derive"]
+
+[dev-dependencies.serde_json]
+version = "1.0"
+
+[dev-dependencies.version-sync]
+version = "0.9"
+
+[features]
+alloc = []
+default = ["std"]
+std = ["alloc"]
+[badges.maintenance]
+status = "actively-developed"