summaryrefslogtreecommitdiffstats
path: root/vendor/icu_locid_transform/Cargo.toml
diff options
context:
space:
mode:
Diffstat (limited to 'vendor/icu_locid_transform/Cargo.toml')
-rw-r--r--vendor/icu_locid_transform/Cargo.toml128
1 files changed, 128 insertions, 0 deletions
diff --git a/vendor/icu_locid_transform/Cargo.toml b/vendor/icu_locid_transform/Cargo.toml
new file mode 100644
index 000000000..b083c54a2
--- /dev/null
+++ b/vendor/icu_locid_transform/Cargo.toml
@@ -0,0 +1,128 @@
+# THIS FILE IS AUTOMATICALLY GENERATED BY CARGO
+#
+# When uploading crates to the registry Cargo will automatically
+# "normalize" Cargo.toml files for maximal compatibility
+# with all versions of Cargo and also rewrite `path` dependencies
+# to registry (e.g., crates.io) dependencies.
+#
+# If you are reading this file be aware that the original Cargo.toml
+# will likely look very different (and much more reasonable).
+# See Cargo.toml.orig for the original contents.
+
+[package]
+edition = "2021"
+rust-version = "1.66"
+name = "icu_locid_transform"
+version = "1.3.2"
+authors = ["The ICU4X Project Developers"]
+include = [
+ "data/**/*",
+ "src/**/*",
+ "examples/**/*",
+ "benches/**/*",
+ "tests/**/*",
+ "Cargo.toml",
+ "LICENSE",
+ "README.md",
+]
+description = "API for Unicode Language and Locale Identifiers canonicalization"
+homepage = "https://icu4x.unicode.org"
+readme = "README.md"
+categories = ["internationalization"]
+license-file = "LICENSE"
+repository = "https://github.com/unicode-org/icu4x"
+
+[package.metadata.cargo-all-features]
+denylist = ["bench"]
+skip_optional_dependencies = true
+
+[package.metadata.docs.rs]
+all-features = true
+
+[lib]
+bench = false
+
+[[test]]
+name = "locale_canonicalizer"
+required-features = ["serde"]
+
+[[bench]]
+name = "locale_canonicalizer"
+harness = false
+
+[dependencies.databake]
+version = "0.1.6"
+features = ["derive"]
+optional = true
+default-features = false
+
+[dependencies.displaydoc]
+version = "0.2.3"
+default-features = false
+
+[dependencies.icu_locid]
+version = "~1.3.2"
+features = ["zerovec"]
+default-features = false
+
+[dependencies.icu_locid_transform_data]
+version = "~1.3.2"
+optional = true
+default-features = false
+
+[dependencies.icu_provider]
+version = "~1.3.2"
+features = ["macros"]
+default-features = false
+
+[dependencies.serde]
+version = "1.0"
+features = [
+ "derive",
+ "alloc",
+]
+optional = true
+default-features = false
+
+[dependencies.tinystr]
+version = "0.7.3"
+features = [
+ "alloc",
+ "zerovec",
+]
+default-features = false
+
+[dependencies.zerovec]
+version = "0.10.0"
+features = ["yoke"]
+default-features = false
+
+[dev-dependencies.serde]
+version = "1.0"
+features = ["derive"]
+
+[dev-dependencies.serde_json]
+version = "1.0"
+
+[features]
+bench = ["serde"]
+compiled_data = ["dep:icu_locid_transform_data"]
+datagen = [
+ "serde",
+ "dep:databake",
+ "zerovec/databake",
+ "icu_locid/databake",
+ "tinystr/databake",
+]
+default = ["compiled_data"]
+serde = [
+ "dep:serde",
+ "icu_locid/serde",
+ "tinystr/serde",
+ "zerovec/serde",
+ "icu_provider/serde",
+]
+std = []
+
+[target."cfg(not(target_arch = \"wasm32\"))".dev-dependencies.criterion]
+version = "0.4"