summaryrefslogtreecommitdiffstats
path: root/vendor/icu_provider/Cargo.toml
diff options
context:
space:
mode:
Diffstat (limited to 'vendor/icu_provider/Cargo.toml')
-rw-r--r--vendor/icu_provider/Cargo.toml155
1 files changed, 155 insertions, 0 deletions
diff --git a/vendor/icu_provider/Cargo.toml b/vendor/icu_provider/Cargo.toml
new file mode 100644
index 000000000..4ed67b0c0
--- /dev/null
+++ b/vendor/icu_provider/Cargo.toml
@@ -0,0 +1,155 @@
+# THIS FILE IS AUTOMATICALLY GENERATED BY CARGO
+#
+# When uploading crates to the registry Cargo will automatically
+# "normalize" Cargo.toml files for maximal compatibility
+# with all versions of Cargo and also rewrite `path` dependencies
+# to registry (e.g., crates.io) dependencies.
+#
+# If you are reading this file be aware that the original Cargo.toml
+# will likely look very different (and much more reasonable).
+# See Cargo.toml.orig for the original contents.
+
+[package]
+edition = "2021"
+name = "icu_provider"
+version = "1.0.1"
+authors = ["The ICU4X Project Developers"]
+include = [
+ "src/**/*",
+ "examples/**/*",
+ "benches/**/*",
+ "tests/**/*",
+ "Cargo.toml",
+ "LICENSE",
+ "README.md",
+]
+description = "Trait and struct definitions for the ICU data provider"
+readme = "README.md"
+categories = ["internationalization"]
+license = "Unicode-DFS-2016"
+repository = "https://github.com/unicode-org/icu4x"
+resolver = "2"
+
+[package.metadata.cargo-all-features]
+skip_optional_dependencies = true
+denylist = [
+ "bench",
+ "macros",
+]
+extra_features = ["serde"]
+
+[package.metadata.docs.rs]
+all-features = true
+
+[dependencies.bincode]
+version = "1.3"
+optional = true
+
+[dependencies.databake]
+version = "0.1.0"
+features = ["derive"]
+optional = true
+
+[dependencies.dhat]
+version = "0.3.0"
+optional = true
+
+[dependencies.displaydoc]
+version = "0.2.3"
+default-features = false
+
+[dependencies.erased-serde]
+version = "0.3"
+features = ["alloc"]
+optional = true
+default-features = false
+
+[dependencies.icu_locid]
+version = "1.0.0"
+
+[dependencies.icu_provider_macros]
+version = "1.0.0"
+optional = true
+
+[dependencies.log]
+version = "0.4"
+optional = true
+
+[dependencies.postcard]
+version = "1.0.0"
+optional = true
+default-features = false
+
+[dependencies.serde]
+version = "1.0"
+features = [
+ "derive",
+ "alloc",
+]
+optional = true
+default-features = false
+
+[dependencies.serde_json]
+version = "1.0"
+features = ["alloc"]
+optional = true
+default-features = false
+
+[dependencies.stable_deref_trait]
+version = "1.2.0"
+default-features = false
+
+[dependencies.writeable]
+version = "0.5"
+
+[dependencies.yoke]
+version = "0.6.2"
+features = ["derive"]
+
+[dependencies.zerofrom]
+version = "0.1.0"
+features = ["derive"]
+
+[dependencies.zerovec]
+version = "0.9"
+features = ["derive"]
+
+[dev-dependencies.serde_json]
+version = "1.0"
+
+[dev-dependencies.static_assertions]
+version = "1.1"
+
+[features]
+datagen = [
+ "dhat",
+ "serde",
+ "erased-serde",
+ "databake",
+ "std",
+ "serde_json",
+ "sync",
+ "yoke/serde",
+]
+default = []
+deserialize_bincode_1 = [
+ "serde",
+ "bincode",
+ "std",
+]
+deserialize_json = [
+ "serde",
+ "serde_json",
+]
+deserialize_postcard_1 = [
+ "serde",
+ "postcard",
+]
+log_error_context = ["log"]
+macros = ["icu_provider_macros"]
+serde = [
+ "dep:serde",
+ "yoke/serde",
+]
+std = ["icu_locid/std"]
+sync = []