summaryrefslogtreecommitdiffstats
path: root/vendor/ignore/Cargo.toml
diff options
context:
space:
mode:
Diffstat (limited to 'vendor/ignore/Cargo.toml')
-rw-r--r--vendor/ignore/Cargo.toml32
1 files changed, 20 insertions, 12 deletions
diff --git a/vendor/ignore/Cargo.toml b/vendor/ignore/Cargo.toml
index 5f823960a..b397dcf8d 100644
--- a/vendor/ignore/Cargo.toml
+++ b/vendor/ignore/Cargo.toml
@@ -3,34 +3,40 @@
# When uploading crates to the registry Cargo will automatically
# "normalize" Cargo.toml files for maximal compatibility
# with all versions of Cargo and also rewrite `path` dependencies
-# to registry (e.g., crates.io) dependencies
+# to registry (e.g., crates.io) dependencies.
#
-# If you believe there's an error in this file please file an
-# issue against the rust-lang/cargo repository. If you're
-# editing this file be aware that the upstream Cargo.toml
-# will likely look very different (and much more reasonable)
+# If you are reading this file be aware that the original Cargo.toml
+# will likely look very different (and much more reasonable).
+# See Cargo.toml.orig for the original contents.
[package]
edition = "2018"
name = "ignore"
-version = "0.4.18"
+version = "0.4.20"
authors = ["Andrew Gallant <jamslam@gmail.com>"]
-description = "A fast library for efficiently matching ignore files such as `.gitignore`\nagainst file paths.\n"
+description = """
+A fast library for efficiently matching ignore files such as `.gitignore`
+against file paths.
+"""
homepage = "https://github.com/BurntSushi/ripgrep/tree/master/crates/ignore"
documentation = "https://docs.rs/ignore"
readme = "README.md"
-keywords = ["glob", "ignore", "gitignore", "pattern", "file"]
-license = "Unlicense/MIT"
+keywords = [
+ "glob",
+ "ignore",
+ "gitignore",
+ "pattern",
+ "file",
+]
+license = "Unlicense OR MIT"
repository = "https://github.com/BurntSushi/ripgrep/tree/master/crates/ignore"
[lib]
name = "ignore"
bench = false
-[dependencies.crossbeam-utils]
-version = "0.8.0"
[dependencies.globset]
-version = "0.4.7"
+version = "0.4.10"
[dependencies.lazy_static]
version = "1.1"
@@ -52,10 +58,12 @@ version = "1"
[dependencies.walkdir]
version = "2.2.7"
+
[dev-dependencies.crossbeam-channel]
version = "0.5.0"
[features]
simd-accel = ["globset/simd-accel"]
+
[target."cfg(windows)".dependencies.winapi-util]
version = "0.1.2"