summaryrefslogtreecommitdiffstats
path: root/vendor/is-terminal/Cargo.toml
diff options
context:
space:
mode:
Diffstat (limited to 'vendor/is-terminal/Cargo.toml')
-rw-r--r--vendor/is-terminal/Cargo.toml15
1 files changed, 8 insertions, 7 deletions
diff --git a/vendor/is-terminal/Cargo.toml b/vendor/is-terminal/Cargo.toml
index 7957a9c4f..e0baea0f1 100644
--- a/vendor/is-terminal/Cargo.toml
+++ b/vendor/is-terminal/Cargo.toml
@@ -11,9 +11,9 @@
[package]
edition = "2018"
-rust-version = "1.48"
+rust-version = "1.63"
name = "is-terminal"
-version = "0.4.7"
+version = "0.4.8"
authors = [
"softprops <d.tangren@gmail.com>",
"Dan Gohman <dev@sunfishcode.online>",
@@ -27,7 +27,7 @@ include = [
"/*.md",
]
description = "Test whether a given stream is a terminal"
-documentation = "http://docs.rs/is-terminal"
+documentation = "https://docs.rs/is-terminal"
readme = "README.md"
keywords = [
"terminal",
@@ -38,9 +38,6 @@ categories = ["command-line-interface"]
license = "MIT"
repository = "https://github.com/sunfishcode/is-terminal"
-[dependencies.io-lifetimes]
-version = "1.0.0"
-
[dev-dependencies.atty]
version = "0.2.14"
@@ -48,9 +45,13 @@ version = "0.2.14"
version = "0.2.110"
[target."cfg(not(any(windows, target_os = \"hermit\", target_os = \"unknown\")))".dependencies.rustix]
-version = "0.37.0"
+version = "0.38.0"
features = ["termios"]
+[target."cfg(not(any(windows, target_os = \"hermit\", target_os = \"unknown\")))".dev-dependencies.rustix]
+version = "0.38.0"
+features = ["stdio"]
+
[target."cfg(target_os = \"hermit\")".dependencies.hermit-abi]
version = "0.3.0"