summaryrefslogtreecommitdiffstats
path: root/vendor/jsonpath_lib/Cargo.toml
diff options
context:
space:
mode:
Diffstat (limited to 'vendor/jsonpath_lib/Cargo.toml')
-rw-r--r--vendor/jsonpath_lib/Cargo.toml47
1 files changed, 47 insertions, 0 deletions
diff --git a/vendor/jsonpath_lib/Cargo.toml b/vendor/jsonpath_lib/Cargo.toml
new file mode 100644
index 000000000..512897cb7
--- /dev/null
+++ b/vendor/jsonpath_lib/Cargo.toml
@@ -0,0 +1,47 @@
+# THIS FILE IS AUTOMATICALLY GENERATED BY CARGO
+#
+# When uploading crates to the registry Cargo will automatically
+# "normalize" Cargo.toml files for maximal compatibility
+# with all versions of Cargo and also rewrite `path` dependencies
+# to registry (e.g., crates.io) dependencies
+#
+# If you believe there's an error in this file please file an
+# issue against the rust-lang/cargo repository. If you're
+# editing this file be aware that the upstream Cargo.toml
+# will likely look very different (and much more reasonable)
+
+[package]
+name = "jsonpath_lib"
+version = "0.2.6"
+authors = ["Changseok Han <freestrings@gmail.com>"]
+description = "It is JsonPath engine written in Rust. it provide a similar API interface in Webassembly and Javascript too. - Webassembly Demo: https://freestrings.github.io/jsonpath"
+documentation = "https://docs.rs/jsonpath_lib/0.2.6/jsonpath_lib"
+readme = "README.md"
+keywords = ["jsonpath", "json", "webassembly", "lua", "query"]
+categories = ["wasm", "parser-implementations", "api-bindings"]
+license = "MIT"
+repository = "https://github.com/freestrings/jsonpath"
+
+[lib]
+name = "jsonpath_lib"
+crate-type = ["cdylib", "rlib"]
+path = "src/lib.rs"
+[dependencies.array_tool]
+version = "1.0.3"
+
+[dependencies.env_logger]
+version = "0.7"
+
+[dependencies.log]
+version = "0.4"
+
+[dependencies.serde]
+version = "1.0"
+features = ["derive"]
+
+[dependencies.serde_json]
+version = "1.0"
+features = ["preserve_order"]
+[badges.travis-ci]
+branch = "master"
+repository = "freestrings/jsonpath"