summaryrefslogtreecommitdiffstats
path: root/vendor/libc/Cargo.toml
diff options
context:
space:
mode:
Diffstat (limited to 'vendor/libc/Cargo.toml')
-rw-r--r--vendor/libc/Cargo.toml9
1 files changed, 5 insertions, 4 deletions
diff --git a/vendor/libc/Cargo.toml b/vendor/libc/Cargo.toml
index 9cccef587..b62faf51c 100644
--- a/vendor/libc/Cargo.toml
+++ b/vendor/libc/Cargo.toml
@@ -11,7 +11,7 @@
[package]
name = "libc"
-version = "0.2.147"
+version = "0.2.148"
authors = ["The Rust Project Developers"]
build = "build.rs"
exclude = [
@@ -42,13 +42,14 @@ license = "MIT OR Apache-2.0"
repository = "https://github.com/rust-lang/libc"
[package.metadata.docs.rs]
-cargo-args = ["-Zbuild-std"]
+cargo-args = ["-Zbuild-std=core"]
default-target = "x86_64-unknown-linux-gnu"
features = [
"const-extern-fn",
"extra_traits",
]
targets = [
+ "aarch64-apple-ios",
"aarch64-linux-android",
"aarch64-pc-windows-msvc",
"aarch64-unknown-freebsd",
@@ -132,12 +133,12 @@ targets = [
"wasm32-unknown-emscripten",
"wasm32-unknown-unknown",
"wasm32-wasi",
+ "x86_64-apple-darwin",
+ "x86_64-apple-ios",
"x86_64-fortanix-unknown-sgx",
"x86_64-linux-android",
"x86_64-pc-solaris",
"x86_64-pc-windows-gnu",
- "x86_64-pc-windows-gnu",
- "x86_64-pc-windows-msvc",
"x86_64-pc-windows-msvc",
"x86_64-unknown-dragonfly",
"x86_64-unknown-freebsd",