summaryrefslogtreecommitdiffstats
path: root/vendor/lock_api/Cargo.toml
diff options
context:
space:
mode:
Diffstat (limited to 'vendor/lock_api/Cargo.toml')
-rw-r--r--vendor/lock_api/Cargo.toml11
1 files changed, 10 insertions, 1 deletions
diff --git a/vendor/lock_api/Cargo.toml b/vendor/lock_api/Cargo.toml
index b1ff8c4db..7a3f3a8ad 100644
--- a/vendor/lock_api/Cargo.toml
+++ b/vendor/lock_api/Cargo.toml
@@ -12,7 +12,7 @@
[package]
edition = "2018"
name = "lock_api"
-version = "0.4.9"
+version = "0.4.10"
authors = ["Amanieu d'Antras <amanieu@gmail.com>"]
description = "Wrappers to create fully-featured Mutex and RwLock types. Compatible with no_std."
keywords = [
@@ -28,6 +28,13 @@ categories = [
license = "MIT OR Apache-2.0"
repository = "https://github.com/Amanieu/parking_lot"
+[package.metadata.docs.rs]
+all-features = true
+rustdoc-args = [
+ "--cfg",
+ "docsrs",
+]
+
[dependencies.owning_ref]
version = "0.4.1"
optional = true
@@ -46,4 +53,6 @@ version = "1.1.0"
[features]
arc_lock = []
+atomic_usize = []
+default = ["atomic_usize"]
nightly = []