summaryrefslogtreecommitdiffstats
path: root/vendor/lsp-types/Cargo.toml
diff options
context:
space:
mode:
Diffstat (limited to 'vendor/lsp-types/Cargo.toml')
-rw-r--r--vendor/lsp-types/Cargo.toml52
1 files changed, 52 insertions, 0 deletions
diff --git a/vendor/lsp-types/Cargo.toml b/vendor/lsp-types/Cargo.toml
new file mode 100644
index 000000000..886afcab7
--- /dev/null
+++ b/vendor/lsp-types/Cargo.toml
@@ -0,0 +1,52 @@
+# THIS FILE IS AUTOMATICALLY GENERATED BY CARGO
+#
+# When uploading crates to the registry Cargo will automatically
+# "normalize" Cargo.toml files for maximal compatibility
+# with all versions of Cargo and also rewrite `path` dependencies
+# to registry (e.g., crates.io) dependencies.
+#
+# If you are reading this file be aware that the original Cargo.toml
+# will likely look very different (and much more reasonable).
+# See Cargo.toml.orig for the original contents.
+
+[package]
+edition = "2018"
+name = "lsp-types"
+version = "0.93.0"
+authors = [
+ "Markus Westerlind <marwes91@gmail.com>",
+ "Bruno Medeiros <bruno.do.medeiros@gmail.com>",
+]
+description = "Types for interaction with a language server, using VSCode's Language Server Protocol"
+documentation = "https://docs.rs/lsp-types"
+readme = "README.md"
+keywords = [
+ "language",
+ "server",
+ "lsp",
+ "vscode",
+ "lsif",
+]
+license = "MIT"
+repository = "https://github.com/gluon-lang/lsp-types"
+
+[dependencies.bitflags]
+version = "1.0.1"
+
+[dependencies.serde]
+version = "1.0.34"
+features = ["derive"]
+
+[dependencies.serde_json]
+version = "1.0.50"
+
+[dependencies.serde_repr]
+version = "0.1"
+
+[dependencies.url]
+version = "2.0.0"
+features = ["serde"]
+
+[features]
+default = []
+proposed = []