summaryrefslogtreecommitdiffstats
path: root/vendor/mdbook/Cargo.toml
diff options
context:
space:
mode:
Diffstat (limited to 'vendor/mdbook/Cargo.toml')
-rw-r--r--vendor/mdbook/Cargo.toml165
1 files changed, 165 insertions, 0 deletions
diff --git a/vendor/mdbook/Cargo.toml b/vendor/mdbook/Cargo.toml
new file mode 100644
index 000000000..2e00e186d
--- /dev/null
+++ b/vendor/mdbook/Cargo.toml
@@ -0,0 +1,165 @@
+# THIS FILE IS AUTOMATICALLY GENERATED BY CARGO
+#
+# When uploading crates to the registry Cargo will automatically
+# "normalize" Cargo.toml files for maximal compatibility
+# with all versions of Cargo and also rewrite `path` dependencies
+# to registry (e.g., crates.io) dependencies.
+#
+# If you are reading this file be aware that the original Cargo.toml
+# will likely look very different (and much more reasonable).
+# See Cargo.toml.orig for the original contents.
+
+[package]
+edition = "2018"
+name = "mdbook"
+version = "0.4.21"
+authors = [
+ "Mathieu David <mathieudavid@mathieudavid.org>",
+ "Michael-F-Bryan <michaelfbryan@gmail.com>",
+ "Matt Ickstadt <mattico8@gmail.com>",
+]
+exclude = ["/guide/*"]
+description = "Creates a book from markdown files"
+documentation = "http://rust-lang.github.io/mdBook/index.html"
+readme = "README.md"
+keywords = [
+ "book",
+ "gitbook",
+ "rustbook",
+ "markdown",
+]
+license = "MPL-2.0"
+repository = "https://github.com/rust-lang/mdBook"
+
+[[bin]]
+name = "mdbook"
+doc = false
+
+[dependencies.ammonia]
+version = "3"
+optional = true
+
+[dependencies.anyhow]
+version = "1.0.28"
+
+[dependencies.chrono]
+version = "0.4"
+
+[dependencies.clap]
+version = "3.0"
+features = ["cargo"]
+
+[dependencies.clap_complete]
+version = "3.0"
+
+[dependencies.elasticlunr-rs]
+version = "3.0.0"
+optional = true
+
+[dependencies.env_logger]
+version = "0.9.0"
+
+[dependencies.futures-util]
+version = "0.3.4"
+optional = true
+
+[dependencies.gitignore]
+version = "1.0"
+optional = true
+
+[dependencies.handlebars]
+version = "4.0"
+
+[dependencies.lazy_static]
+version = "1.0"
+
+[dependencies.log]
+version = "0.4"
+
+[dependencies.memchr]
+version = "2.0"
+
+[dependencies.notify]
+version = "4.0"
+optional = true
+
+[dependencies.opener]
+version = "0.5"
+
+[dependencies.pulldown-cmark]
+version = "0.9.1"
+default-features = false
+
+[dependencies.regex]
+version = "1.5.5"
+
+[dependencies.serde]
+version = "1.0"
+features = ["derive"]
+
+[dependencies.serde_json]
+version = "1.0"
+
+[dependencies.shlex]
+version = "1"
+
+[dependencies.tempfile]
+version = "3.0"
+
+[dependencies.tokio]
+version = "1"
+features = [
+ "macros",
+ "rt-multi-thread",
+]
+optional = true
+
+[dependencies.toml]
+version = "0.5.1"
+
+[dependencies.topological-sort]
+version = "0.1.0"
+
+[dependencies.warp]
+version = "0.3.2"
+features = ["websocket"]
+optional = true
+default-features = false
+
+[dev-dependencies.assert_cmd]
+version = "1"
+
+[dev-dependencies.predicates]
+version = "2"
+
+[dev-dependencies.pretty_assertions]
+version = "1.2.1"
+
+[dev-dependencies.select]
+version = "0.5"
+
+[dev-dependencies.semver]
+version = "1.0"
+
+[dev-dependencies.walkdir]
+version = "2.0"
+
+[features]
+default = [
+ "watch",
+ "serve",
+ "search",
+]
+search = [
+ "elasticlunr-rs",
+ "ammonia",
+]
+serve = [
+ "futures-util",
+ "tokio",
+ "warp",
+]
+watch = [
+ "notify",
+ "gitignore",
+]