summaryrefslogtreecommitdiffstats
path: root/vendor/memchr/Cargo.toml
diff options
context:
space:
mode:
Diffstat (limited to 'vendor/memchr/Cargo.toml')
-rw-r--r--vendor/memchr/Cargo.toml78
1 files changed, 78 insertions, 0 deletions
diff --git a/vendor/memchr/Cargo.toml b/vendor/memchr/Cargo.toml
new file mode 100644
index 000000000..630195281
--- /dev/null
+++ b/vendor/memchr/Cargo.toml
@@ -0,0 +1,78 @@
+# THIS FILE IS AUTOMATICALLY GENERATED BY CARGO
+#
+# When uploading crates to the registry Cargo will automatically
+# "normalize" Cargo.toml files for maximal compatibility
+# with all versions of Cargo and also rewrite `path` dependencies
+# to registry (e.g., crates.io) dependencies.
+#
+# If you are reading this file be aware that the original Cargo.toml
+# will likely look very different (and much more reasonable).
+# See Cargo.toml.orig for the original contents.
+
+[package]
+edition = "2018"
+name = "memchr"
+version = "2.5.0"
+authors = [
+ "Andrew Gallant <jamslam@gmail.com>",
+ "bluss",
+]
+exclude = [
+ "/bench",
+ "/.github",
+ "/fuzz",
+]
+description = "Safe interface to memchr."
+homepage = "https://github.com/BurntSushi/memchr"
+documentation = "https://docs.rs/memchr/"
+readme = "README.md"
+keywords = [
+ "memchr",
+ "char",
+ "scan",
+ "strchr",
+ "string",
+]
+license = "Unlicense/MIT"
+repository = "https://github.com/BurntSushi/memchr"
+
+[profile.bench]
+debug = true
+
+[profile.release]
+debug = true
+
+[profile.test]
+opt-level = 3
+debug = true
+
+[lib]
+name = "memchr"
+bench = false
+
+[dependencies.compiler_builtins]
+version = "0.1.2"
+optional = true
+
+[dependencies.core]
+version = "1.0.0"
+optional = true
+package = "rustc-std-workspace-core"
+
+[dependencies.libc]
+version = "0.2.18"
+optional = true
+default-features = false
+
+[dev-dependencies.quickcheck]
+version = "1.0.3"
+default-features = false
+
+[features]
+default = ["std"]
+rustc-dep-of-std = [
+ "core",
+ "compiler_builtins",
+]
+std = []
+use_std = ["std"]