summaryrefslogtreecommitdiffstats
path: root/vendor/miow/Cargo.toml
diff options
context:
space:
mode:
Diffstat (limited to 'vendor/miow/Cargo.toml')
-rw-r--r--vendor/miow/Cargo.toml40
1 files changed, 32 insertions, 8 deletions
diff --git a/vendor/miow/Cargo.toml b/vendor/miow/Cargo.toml
index fff390fb5..2538f4b19 100644
--- a/vendor/miow/Cargo.toml
+++ b/vendor/miow/Cargo.toml
@@ -12,21 +12,45 @@
[package]
edition = "2018"
name = "miow"
-version = "0.4.0"
+version = "0.5.0"
authors = ["Alex Crichton <alex@alexcrichton.com>"]
-description = "A zero overhead I/O library for Windows, focusing on IOCP and Async I/O\nabstractions.\n"
+description = """
+A zero overhead I/O library for Windows, focusing on IOCP and async I/O
+abstractions.
+"""
homepage = "https://github.com/yoshuawuyts/miow"
-documentation = "https://docs.rs/miow/0.3/x86_64-pc-windows-msvc/miow/"
+documentation = "https://docs.rs/miow"
readme = "README.md"
-keywords = ["iocp", "windows", "io", "overlapped"]
-license = "MIT/Apache-2.0"
+keywords = [
+ "iocp",
+ "windows",
+ "io",
+ "overlapped",
+]
+license = "MIT OR Apache-2.0"
repository = "https://github.com/yoshuawuyts/miow"
+
[package.metadata.docs.rs]
default-target = "x86_64-pc-windows-msvc"
-targets = ["aarch64-pc-windows-msvc", "i686-pc-windows-msvc", "x86_64-pc-windows-msvc"]
+targets = [
+ "aarch64-pc-windows-msvc",
+ "i686-pc-windows-msvc",
+ "x86_64-pc-windows-msvc",
+]
+
[dependencies.windows-sys]
-version = "0.28.0"
-features = ["Win32_Foundation", "Win32_Networking_WinSock", "Win32_NetworkManagement_IpHelper", "Win32_Security", "Win32_Storage_FileSystem", "Win32_System_IO", "Win32_System_Pipes", "Win32_System_Threading", "Win32_System_WindowsProgramming"]
+version = "0.42.0"
+features = [
+ "Win32_Foundation",
+ "Win32_Networking_WinSock",
+ "Win32_Security",
+ "Win32_Storage_FileSystem",
+ "Win32_System_IO",
+ "Win32_System_Pipes",
+ "Win32_System_Threading",
+ "Win32_System_WindowsProgramming",
+]
+
[dev-dependencies.rand]
version = "0.8.0"