summaryrefslogtreecommitdiffstats
path: root/vendor/object-0.26.2/Cargo.toml
diff options
context:
space:
mode:
Diffstat (limited to 'vendor/object-0.26.2/Cargo.toml')
-rw-r--r--vendor/object-0.26.2/Cargo.toml101
1 files changed, 101 insertions, 0 deletions
diff --git a/vendor/object-0.26.2/Cargo.toml b/vendor/object-0.26.2/Cargo.toml
new file mode 100644
index 000000000..7ce7bdffd
--- /dev/null
+++ b/vendor/object-0.26.2/Cargo.toml
@@ -0,0 +1,101 @@
+# THIS FILE IS AUTOMATICALLY GENERATED BY CARGO
+#
+# When uploading crates to the registry Cargo will automatically
+# "normalize" Cargo.toml files for maximal compatibility
+# with all versions of Cargo and also rewrite `path` dependencies
+# to registry (e.g., crates.io) dependencies
+#
+# If you believe there's an error in this file please file an
+# issue against the rust-lang/cargo repository. If you're
+# editing this file be aware that the upstream Cargo.toml
+# will likely look very different (and much more reasonable)
+
+[package]
+edition = "2018"
+name = "object"
+version = "0.26.2"
+exclude = ["/.coveralls.yml", "/.travis.yml"]
+description = "A unified interface for reading and writing object file formats."
+keywords = ["object", "elf", "mach-o", "pe", "coff"]
+license = "Apache-2.0/MIT"
+repository = "https://github.com/gimli-rs/object"
+[package.metadata.docs.rs]
+features = ["all"]
+
+[[example]]
+name = "ar"
+required-features = ["read_core", "archive"]
+
+[[example]]
+name = "objcopy"
+required-features = ["read", "write"]
+
+[[example]]
+name = "objdump"
+required-features = ["read"]
+
+[[example]]
+name = "objectmap"
+required-features = ["read_core"]
+
+[[example]]
+name = "nm"
+required-features = ["read"]
+
+[[example]]
+name = "readobj"
+required-features = ["read"]
+[dependencies.alloc]
+version = "1.0.0"
+optional = true
+package = "rustc-std-workspace-alloc"
+
+[dependencies.compiler_builtins]
+version = "0.1.2"
+optional = true
+
+[dependencies.core]
+version = "1.0.0"
+optional = true
+package = "rustc-std-workspace-core"
+
+[dependencies.crc32fast]
+version = "1.2"
+optional = true
+
+[dependencies.flate2]
+version = "1"
+optional = true
+
+[dependencies.indexmap]
+version = "1.1"
+optional = true
+
+[dependencies.memchr]
+version = "2.4.1"
+default-features = false
+
+[dependencies.wasmparser]
+version = "0.57"
+optional = true
+[dev-dependencies.memmap2]
+version = "0.3"
+
+[features]
+all = ["read", "write", "std", "compression", "wasm"]
+archive = []
+cargo-all = []
+coff = []
+compression = ["flate2", "std"]
+default = ["read", "compression"]
+elf = []
+macho = []
+pe = ["coff"]
+read = ["read_core", "archive", "coff", "elf", "macho", "pe", "unaligned"]
+read_core = []
+rustc-dep-of-std = ["core", "compiler_builtins", "alloc", "memchr/rustc-dep-of-std"]
+std = ["memchr/std"]
+unaligned = []
+wasm = ["wasmparser"]
+write = ["write_core", "coff", "elf", "macho"]
+write_core = ["crc32fast", "indexmap", "std"]