summaryrefslogtreecommitdiffstats
path: root/vendor/openssl-sys/Cargo.toml
diff options
context:
space:
mode:
Diffstat (limited to 'vendor/openssl-sys/Cargo.toml')
-rw-r--r--vendor/openssl-sys/Cargo.toml61
1 files changed, 61 insertions, 0 deletions
diff --git a/vendor/openssl-sys/Cargo.toml b/vendor/openssl-sys/Cargo.toml
new file mode 100644
index 000000000..80afc7c48
--- /dev/null
+++ b/vendor/openssl-sys/Cargo.toml
@@ -0,0 +1,61 @@
+# THIS FILE IS AUTOMATICALLY GENERATED BY CARGO
+#
+# When uploading crates to the registry Cargo will automatically
+# "normalize" Cargo.toml files for maximal compatibility
+# with all versions of Cargo and also rewrite `path` dependencies
+# to registry (e.g., crates.io) dependencies.
+#
+# If you are reading this file be aware that the original Cargo.toml
+# will likely look very different (and much more reasonable).
+# See Cargo.toml.orig for the original contents.
+
+[package]
+edition = "2018"
+name = "openssl-sys"
+version = "0.9.84"
+authors = [
+ "Alex Crichton <alex@alexcrichton.com>",
+ "Steven Fackler <sfackler@gmail.com>",
+]
+build = "build/main.rs"
+links = "openssl"
+description = "FFI bindings to OpenSSL"
+readme = "README.md"
+categories = [
+ "cryptography",
+ "external-ffi-bindings",
+]
+license = "MIT"
+repository = "https://github.com/sfackler/rust-openssl"
+
+[package.metadata.pkg-config]
+openssl = "1.0.1"
+
+[dependencies.bssl-sys]
+version = "0.1.0"
+optional = true
+
+[dependencies.libc]
+version = "0.2"
+
+[build-dependencies.bindgen]
+version = "0.64.0"
+features = ["experimental"]
+optional = true
+
+[build-dependencies.cc]
+version = "1.0"
+
+[build-dependencies.openssl-src]
+version = "111"
+optional = true
+
+[build-dependencies.pkg-config]
+version = "0.3.9"
+
+[features]
+unstable_boringssl = ["bssl-sys"]
+vendored = ["openssl-src"]
+
+[target."cfg(target_env = \"msvc\")".build-dependencies.vcpkg]
+version = "0.2.8"