summaryrefslogtreecommitdiffstats
path: root/vendor/overload/Cargo.toml
diff options
context:
space:
mode:
Diffstat (limited to '')
-rw-r--r--vendor/overload/Cargo.toml (renamed from vendor/rls-data/Cargo.toml)24
1 files changed, 8 insertions, 16 deletions
diff --git a/vendor/rls-data/Cargo.toml b/vendor/overload/Cargo.toml
index 54d416498..1e0fbc514 100644
--- a/vendor/rls-data/Cargo.toml
+++ b/vendor/overload/Cargo.toml
@@ -12,19 +12,11 @@
[package]
edition = "2018"
-name = "rls-data"
-version = "0.19.1"
-authors = ["Nick Cameron <ncameron@mozilla.com>"]
-description = "Data structures used by the RLS and Rust compiler"
-categories = ["development-tools"]
-license = "Apache-2.0/MIT"
-repository = "https://github.com/rust-lang/rls"
-[dependencies.rls-span]
-version = "0.5.0"
-
-[dependencies.serde]
-version = "1.0"
-
-[features]
-default = ["derive"]
-derive = ["serde/derive", "rls-span/derive"]
+name = "overload"
+version = "0.1.1"
+authors = ["Daniel Salvadori <danaugrs@gmail.com>"]
+description = "Provides a macro to simplify operator overloading."
+keywords = ["operator", "overloading", "macro", "op"]
+categories = ["rust-patterns"]
+license = "MIT"
+repository = "https://github.com/danaugrs/overload"