summaryrefslogtreecommitdiffstats
path: root/vendor/p384/Cargo.toml
diff options
context:
space:
mode:
Diffstat (limited to 'vendor/p384/Cargo.toml')
-rw-r--r--vendor/p384/Cargo.toml35
1 files changed, 21 insertions, 14 deletions
diff --git a/vendor/p384/Cargo.toml b/vendor/p384/Cargo.toml
index c3d50806e..b8bf640de 100644
--- a/vendor/p384/Cargo.toml
+++ b/vendor/p384/Cargo.toml
@@ -11,17 +11,17 @@
[package]
edition = "2021"
-rust-version = "1.57"
+rust-version = "1.65"
name = "p384"
-version = "0.11.2"
+version = "0.13.0"
authors = [
"RustCrypto Developers",
"Frank Denis <github@pureftpd.org>",
]
description = """
Pure Rust implementation of the NIST P-384 (a.k.a. secp384r1) elliptic curve
-with support for ECDH, ECDSA signing/verification, and general purpose curve
-arithmetic support.
+as defined in SP 800-186 with support for ECDH, ECDSA signing/verification,
+and general purpose curve arithmetic support.
"""
documentation = "https://docs.rs/p384"
readme = "README.md"
@@ -37,7 +37,6 @@ categories = [
]
license = "Apache-2.0 OR MIT"
repository = "https://github.com/RustCrypto/elliptic-curves/tree/master/p384"
-resolver = "2"
[package.metadata.docs.rs]
rustdoc-args = [
@@ -55,14 +54,14 @@ name = "scalar"
harness = false
[dependencies.ecdsa-core]
-version = "0.14"
+version = "0.16"
features = ["der"]
optional = true
default-features = false
package = "ecdsa"
[dependencies.elliptic-curve]
-version = "0.12.3"
+version = "0.13"
features = [
"hazmat",
"sec1",
@@ -73,8 +72,11 @@ default-features = false
version = "0.3"
optional = true
+[dependencies.primeorder]
+version = "0.13"
+
[dependencies.serdect]
-version = "0.1"
+version = "0.2"
optional = true
default-features = false
@@ -87,10 +89,10 @@ default-features = false
version = "0.3"
[dev-dependencies.criterion]
-version = "0.3"
+version = "0.4"
[dev-dependencies.ecdsa-core]
-version = "0.14"
+version = "0.16"
features = ["dev"]
default-features = false
package = "ecdsa"
@@ -99,13 +101,17 @@ package = "ecdsa"
version = "0.3"
[dev-dependencies.proptest]
-version = "1.0"
+version = "1.1"
[dev-dependencies.rand_core]
version = "0.6"
features = ["getrandom"]
[features]
+alloc = [
+ "ecdsa-core?/alloc",
+ "elliptic-curve/alloc",
+]
arithmetic = [
"elliptic-curve/arithmetic",
"elliptic-curve/digest",
@@ -131,8 +137,8 @@ ecdh = [
]
ecdsa = [
"arithmetic",
- "ecdsa-core/sign",
- "ecdsa-core/verify",
+ "ecdsa-core/signing",
+ "ecdsa-core/verifying",
"sha384",
]
expose-field = ["arithmetic"]
@@ -160,7 +166,8 @@ sha384 = [
"sha2",
]
std = [
- "ecdsa-core/std",
+ "alloc",
+ "ecdsa-core?/std",
"elliptic-curve/std",
]
test-vectors = ["hex-literal"]