summaryrefslogtreecommitdiffstats
path: root/vendor/packed_simd_2/Cargo.toml
diff options
context:
space:
mode:
Diffstat (limited to 'vendor/packed_simd_2/Cargo.toml')
-rw-r--r--vendor/packed_simd_2/Cargo.toml43
1 files changed, 28 insertions, 15 deletions
diff --git a/vendor/packed_simd_2/Cargo.toml b/vendor/packed_simd_2/Cargo.toml
index 61fbb47fc..86239f96c 100644
--- a/vendor/packed_simd_2/Cargo.toml
+++ b/vendor/packed_simd_2/Cargo.toml
@@ -3,28 +3,37 @@
# When uploading crates to the registry Cargo will automatically
# "normalize" Cargo.toml files for maximal compatibility
# with all versions of Cargo and also rewrite `path` dependencies
-# to registry (e.g., crates.io) dependencies
+# to registry (e.g., crates.io) dependencies.
#
-# If you believe there's an error in this file please file an
-# issue against the rust-lang/cargo repository. If you're
-# editing this file be aware that the upstream Cargo.toml
-# will likely look very different (and much more reasonable)
+# If you are reading this file be aware that the original Cargo.toml
+# will likely look very different (and much more reasonable).
+# See Cargo.toml.orig for the original contents.
[package]
edition = "2018"
name = "packed_simd_2"
-version = "0.3.4"
-authors = ["Gonzalo Brito Gadeschi <gonzalobg88@gmail.com>", "Jubilee Young <workingjubilee@gmail.com>"]
+version = "0.3.8"
build = "build.rs"
description = "Portable Packed SIMD vectors"
-homepage = "https://github.com/rust-lang-nursery/packed_simd"
+homepage = "https://github.com/rust-lang/packed_simd"
documentation = "https://docs.rs/crate/packed_simd/"
-keywords = ["simd", "vector", "portability"]
-categories = ["hardware-support", "concurrency", "no-std", "data-structures"]
-license = "MIT/Apache-2.0"
-repository = "https://github.com/rust-lang-nursery/packed_simd"
+readme = "README.md"
+keywords = [
+ "simd",
+ "vector",
+ "portability",
+]
+categories = [
+ "hardware-support",
+ "concurrency",
+ "no-std",
+ "data-structures",
+]
+license = "MIT OR Apache-2.0"
+repository = "https://github.com/rust-lang/packed_simd"
+
[dependencies.cfg-if]
-version = "0.1.10"
+version = "1.0.0"
[dependencies.core_arch]
version = "0.1.5"
@@ -32,6 +41,7 @@ optional = true
[dependencies.libm]
version = "0.1.4"
+
[dev-dependencies.arrayvec]
version = "^0.5"
default-features = false
@@ -43,14 +53,17 @@ version = "^0.1.3"
default = []
into_bits = []
libcore_neon = []
+
[target."cfg(target_arch = \"x86_64\")".dependencies.sleef-sys]
version = "0.1.2"
optional = true
+
[target.wasm32-unknown-unknown.dev-dependencies.wasm-bindgen]
-version = "=0.2.52"
+version = "=0.2.73"
[target.wasm32-unknown-unknown.dev-dependencies.wasm-bindgen-test]
-version = "=0.3.2"
+version = "=0.3.23"
+
[badges.appveyor]
repository = "rust-lang/packed_simd"