summaryrefslogtreecommitdiffstats
path: root/vendor/parking_lot-0.11.2/Cargo.toml
diff options
context:
space:
mode:
Diffstat (limited to 'vendor/parking_lot-0.11.2/Cargo.toml')
-rw-r--r--vendor/parking_lot-0.11.2/Cargo.toml46
1 files changed, 46 insertions, 0 deletions
diff --git a/vendor/parking_lot-0.11.2/Cargo.toml b/vendor/parking_lot-0.11.2/Cargo.toml
new file mode 100644
index 000000000..549151b6e
--- /dev/null
+++ b/vendor/parking_lot-0.11.2/Cargo.toml
@@ -0,0 +1,46 @@
+# THIS FILE IS AUTOMATICALLY GENERATED BY CARGO
+#
+# When uploading crates to the registry Cargo will automatically
+# "normalize" Cargo.toml files for maximal compatibility
+# with all versions of Cargo and also rewrite `path` dependencies
+# to registry (e.g., crates.io) dependencies.
+#
+# If you are reading this file be aware that the original Cargo.toml
+# will likely look very different (and much more reasonable).
+# See Cargo.toml.orig for the original contents.
+
+[package]
+edition = "2018"
+name = "parking_lot"
+version = "0.11.2"
+authors = ["Amanieu d'Antras <amanieu@gmail.com>"]
+description = "More compact and efficient implementations of the standard synchronization primitives."
+readme = "README.md"
+keywords = ["mutex", "condvar", "rwlock", "once", "thread"]
+categories = ["concurrency"]
+license = "Apache-2.0/MIT"
+repository = "https://github.com/Amanieu/parking_lot"
+[dependencies.instant]
+version = "0.1.9"
+
+[dependencies.lock_api]
+version = "0.4.5"
+
+[dependencies.parking_lot_core]
+version = "0.8.4"
+[dev-dependencies.bincode]
+version = "1.3.3"
+
+[dev-dependencies.rand]
+version = "0.8.3"
+
+[features]
+arc_lock = ["lock_api/arc_lock"]
+deadlock_detection = ["parking_lot_core/deadlock_detection"]
+default = []
+nightly = ["parking_lot_core/nightly", "lock_api/nightly"]
+owning_ref = ["lock_api/owning_ref"]
+send_guard = []
+serde = ["lock_api/serde"]
+stdweb = ["instant/stdweb"]
+wasm-bindgen = ["instant/wasm-bindgen"]