summaryrefslogtreecommitdiffstats
path: root/vendor/rand-0.7.3/Cargo.toml
diff options
context:
space:
mode:
Diffstat (limited to 'vendor/rand-0.7.3/Cargo.toml')
-rw-r--r--vendor/rand-0.7.3/Cargo.toml80
1 files changed, 0 insertions, 80 deletions
diff --git a/vendor/rand-0.7.3/Cargo.toml b/vendor/rand-0.7.3/Cargo.toml
deleted file mode 100644
index 78a29b0e1..000000000
--- a/vendor/rand-0.7.3/Cargo.toml
+++ /dev/null
@@ -1,80 +0,0 @@
-# THIS FILE IS AUTOMATICALLY GENERATED BY CARGO
-#
-# When uploading crates to the registry Cargo will automatically
-# "normalize" Cargo.toml files for maximal compatibility
-# with all versions of Cargo and also rewrite `path` dependencies
-# to registry (e.g., crates.io) dependencies
-#
-# If you believe there's an error in this file please file an
-# issue against the rust-lang/cargo repository. If you're
-# editing this file be aware that the upstream Cargo.toml
-# will likely look very different (and much more reasonable)
-
-[package]
-edition = "2018"
-name = "rand"
-version = "0.7.3"
-authors = ["The Rand Project Developers", "The Rust Project Developers"]
-exclude = ["/utils/*", "/.travis.yml", "/appveyor.yml", ".gitignore"]
-autobenches = true
-description = "Random number generators and other randomness functionality.\n"
-homepage = "https://crates.io/crates/rand"
-documentation = "https://rust-random.github.io/rand/"
-readme = "README.md"
-keywords = ["random", "rng"]
-categories = ["algorithms", "no-std"]
-license = "MIT OR Apache-2.0"
-repository = "https://github.com/rust-random/rand"
-[package.metadata.docs.rs]
-all-features = true
-[dependencies.getrandom_package]
-version = "0.1.1"
-optional = true
-package = "getrandom"
-
-[dependencies.log]
-version = "0.4.4"
-optional = true
-
-[dependencies.packed_simd]
-version = "0.3"
-features = ["into_bits"]
-optional = true
-
-[dependencies.rand_core]
-version = "0.5.1"
-
-[dependencies.rand_pcg]
-version = "0.2"
-optional = true
-[dev-dependencies.rand_hc]
-version = "0.2"
-
-[dev-dependencies.rand_pcg]
-version = "0.2"
-
-[features]
-alloc = ["rand_core/alloc"]
-default = ["std"]
-getrandom = ["getrandom_package", "rand_core/getrandom"]
-nightly = ["simd_support"]
-serde1 = []
-simd_support = ["packed_simd"]
-small_rng = ["rand_pcg"]
-std = ["rand_core/std", "rand_chacha/std", "alloc", "getrandom", "libc"]
-stdweb = ["getrandom_package/stdweb"]
-wasm-bindgen = ["getrandom_package/wasm-bindgen"]
-[target."cfg(not(target_os = \"emscripten\"))".dependencies.rand_chacha]
-version = "0.2.1"
-default-features = false
-[target."cfg(target_os = \"emscripten\")".dependencies.rand_hc]
-version = "0.2"
-[target."cfg(unix)".dependencies.libc]
-version = "0.2.22"
-optional = true
-default-features = false
-[badges.appveyor]
-repository = "rust-random/rand"
-
-[badges.travis-ci]
-repository = "rust-random/rand"