summaryrefslogtreecommitdiffstats
path: root/vendor/rand_core/Cargo.toml
diff options
context:
space:
mode:
Diffstat (limited to 'vendor/rand_core/Cargo.toml')
-rw-r--r--vendor/rand_core/Cargo.toml43
1 files changed, 31 insertions, 12 deletions
diff --git a/vendor/rand_core/Cargo.toml b/vendor/rand_core/Cargo.toml
index 51b8385ea..fd8c96d9b 100644
--- a/vendor/rand_core/Cargo.toml
+++ b/vendor/rand_core/Cargo.toml
@@ -3,32 +3,47 @@
# When uploading crates to the registry Cargo will automatically
# "normalize" Cargo.toml files for maximal compatibility
# with all versions of Cargo and also rewrite `path` dependencies
-# to registry (e.g., crates.io) dependencies
+# to registry (e.g., crates.io) dependencies.
#
-# If you believe there's an error in this file please file an
-# issue against the rust-lang/cargo repository. If you're
-# editing this file be aware that the upstream Cargo.toml
-# will likely look very different (and much more reasonable)
+# If you are reading this file be aware that the original Cargo.toml
+# will likely look very different (and much more reasonable).
+# See Cargo.toml.orig for the original contents.
[package]
edition = "2018"
name = "rand_core"
-version = "0.6.2"
-authors = ["The Rand Project Developers", "The Rust Project Developers"]
-description = "Core random number generator traits and tools for implementation.\n"
+version = "0.6.4"
+authors = [
+ "The Rand Project Developers",
+ "The Rust Project Developers",
+]
+description = """
+Core random number generator traits and tools for implementation.
+"""
homepage = "https://rust-random.github.io/book"
documentation = "https://docs.rs/rand_core"
readme = "README.md"
-keywords = ["random", "rng"]
-categories = ["algorithms", "no-std"]
+keywords = [
+ "random",
+ "rng",
+]
+categories = [
+ "algorithms",
+ "no-std",
+]
license = "MIT OR Apache-2.0"
repository = "https://github.com/rust-random/rand"
+
[package.metadata.docs.rs]
all-features = true
-rustdoc-args = ["--cfg", "doc_cfg"]
+rustdoc-args = [
+ "--cfg",
+ "doc_cfg",
+]
[package.metadata.playground]
all-features = true
+
[dependencies.getrandom]
version = "0.2"
optional = true
@@ -41,4 +56,8 @@ optional = true
[features]
alloc = []
serde1 = ["serde"]
-std = ["alloc", "getrandom", "getrandom/std"]
+std = [
+ "alloc",
+ "getrandom",
+ "getrandom/std",
+]