summaryrefslogtreecommitdiffstats
path: root/vendor/rand_xorshift/Cargo.toml
diff options
context:
space:
mode:
Diffstat (limited to 'vendor/rand_xorshift/Cargo.toml')
-rw-r--r--vendor/rand_xorshift/Cargo.toml20
1 files changed, 8 insertions, 12 deletions
diff --git a/vendor/rand_xorshift/Cargo.toml b/vendor/rand_xorshift/Cargo.toml
index 0260d1315..335c5d1d0 100644
--- a/vendor/rand_xorshift/Cargo.toml
+++ b/vendor/rand_xorshift/Cargo.toml
@@ -13,30 +13,26 @@
[package]
edition = "2018"
name = "rand_xorshift"
-version = "0.2.0"
+version = "0.3.0"
authors = ["The Rand Project Developers", "The Rust Project Developers"]
description = "Xorshift random number generator\n"
-homepage = "https://crates.io/crates/rand_xorshift"
-documentation = "https://rust-random.github.io/rand/rand_xorshift/"
+homepage = "https://rust-random.github.io/book"
+documentation = "https://docs.rs/rand_xorshift"
readme = "README.md"
keywords = ["random", "rng", "xorshift"]
categories = ["algorithms", "no-std"]
-license = "MIT/Apache-2.0"
-repository = "https://github.com/rust-random/rand"
+license = "MIT OR Apache-2.0"
+repository = "https://github.com/rust-random/rngs"
[dependencies.rand_core]
-version = "0.5"
+version = "0.6"
[dependencies.serde]
-version = "1"
+version = "1.0.118"
features = ["derive"]
optional = true
+default-features = false
[dev-dependencies.bincode]
version = "1"
[features]
serde1 = ["serde"]
-[badges.appveyor]
-repository = "rust-random/rand"
-
-[badges.travis-ci]
-repository = "rust-random/rand"