summaryrefslogtreecommitdiffstats
path: root/vendor/rand_xorshift/Cargo.toml
diff options
context:
space:
mode:
Diffstat (limited to 'vendor/rand_xorshift/Cargo.toml')
-rw-r--r--vendor/rand_xorshift/Cargo.toml42
1 files changed, 42 insertions, 0 deletions
diff --git a/vendor/rand_xorshift/Cargo.toml b/vendor/rand_xorshift/Cargo.toml
new file mode 100644
index 000000000..0260d1315
--- /dev/null
+++ b/vendor/rand_xorshift/Cargo.toml
@@ -0,0 +1,42 @@
+# THIS FILE IS AUTOMATICALLY GENERATED BY CARGO
+#
+# When uploading crates to the registry Cargo will automatically
+# "normalize" Cargo.toml files for maximal compatibility
+# with all versions of Cargo and also rewrite `path` dependencies
+# to registry (e.g., crates.io) dependencies
+#
+# If you believe there's an error in this file please file an
+# issue against the rust-lang/cargo repository. If you're
+# editing this file be aware that the upstream Cargo.toml
+# will likely look very different (and much more reasonable)
+
+[package]
+edition = "2018"
+name = "rand_xorshift"
+version = "0.2.0"
+authors = ["The Rand Project Developers", "The Rust Project Developers"]
+description = "Xorshift random number generator\n"
+homepage = "https://crates.io/crates/rand_xorshift"
+documentation = "https://rust-random.github.io/rand/rand_xorshift/"
+readme = "README.md"
+keywords = ["random", "rng", "xorshift"]
+categories = ["algorithms", "no-std"]
+license = "MIT/Apache-2.0"
+repository = "https://github.com/rust-random/rand"
+[dependencies.rand_core]
+version = "0.5"
+
+[dependencies.serde]
+version = "1"
+features = ["derive"]
+optional = true
+[dev-dependencies.bincode]
+version = "1"
+
+[features]
+serde1 = ["serde"]
+[badges.appveyor]
+repository = "rust-random/rand"
+
+[badges.travis-ci]
+repository = "rust-random/rand"