summaryrefslogtreecommitdiffstats
path: root/vendor/rand_xoshiro/Cargo.toml
diff options
context:
space:
mode:
Diffstat (limited to 'vendor/rand_xoshiro/Cargo.toml')
-rw-r--r--vendor/rand_xoshiro/Cargo.toml37
1 files changed, 37 insertions, 0 deletions
diff --git a/vendor/rand_xoshiro/Cargo.toml b/vendor/rand_xoshiro/Cargo.toml
new file mode 100644
index 000000000..e5773f88c
--- /dev/null
+++ b/vendor/rand_xoshiro/Cargo.toml
@@ -0,0 +1,37 @@
+# THIS FILE IS AUTOMATICALLY GENERATED BY CARGO
+#
+# When uploading crates to the registry Cargo will automatically
+# "normalize" Cargo.toml files for maximal compatibility
+# with all versions of Cargo and also rewrite `path` dependencies
+# to registry (e.g., crates.io) dependencies
+#
+# If you believe there's an error in this file please file an
+# issue against the rust-lang/cargo repository. If you're
+# editing this file be aware that the upstream Cargo.toml
+# will likely look very different (and much more reasonable)
+
+[package]
+edition = "2018"
+name = "rand_xoshiro"
+version = "0.6.0"
+authors = ["The Rand Project Developers"]
+description = "Xoshiro, xoroshiro and splitmix64 random number generators"
+homepage = "https://rust-random.github.io/book"
+documentation = "https://docs.rs/rand_xoshiro"
+readme = "README.md"
+keywords = ["random", "rng"]
+categories = ["algorithms"]
+license = "MIT OR Apache-2.0"
+repository = "https://github.com/rust-random/rngs"
+[dependencies.rand_core]
+version = "0.6"
+
+[dependencies.serde]
+version = "1"
+features = ["derive"]
+optional = true
+[dev-dependencies.bincode]
+version = "1"
+
+[features]
+serde1 = ["serde"]