summaryrefslogtreecommitdiffstats
path: root/vendor/redox_users/Cargo.toml
diff options
context:
space:
mode:
Diffstat (limited to 'vendor/redox_users/Cargo.toml')
-rw-r--r--vendor/redox_users/Cargo.toml37
1 files changed, 37 insertions, 0 deletions
diff --git a/vendor/redox_users/Cargo.toml b/vendor/redox_users/Cargo.toml
new file mode 100644
index 000000000..5a21c8fa6
--- /dev/null
+++ b/vendor/redox_users/Cargo.toml
@@ -0,0 +1,37 @@
+# THIS FILE IS AUTOMATICALLY GENERATED BY CARGO
+#
+# When uploading crates to the registry Cargo will automatically
+# "normalize" Cargo.toml files for maximal compatibility
+# with all versions of Cargo and also rewrite `path` dependencies
+# to registry (e.g., crates.io) dependencies
+#
+# If you believe there's an error in this file please file an
+# issue against the rust-lang/cargo repository. If you're
+# editing this file be aware that the upstream Cargo.toml
+# will likely look very different (and much more reasonable)
+
+[package]
+edition = "2018"
+name = "redox_users"
+version = "0.4.0"
+authors = ["Jose Narvaez <goyox86@gmail.com>", "Wesley Hershberger <mggmugginsmc@gmail.com>"]
+description = "A Rust library to access Redox users and groups functionality"
+documentation = "https://docs.rs/redox_users"
+readme = "README.md"
+keywords = ["redox", "auth"]
+license = "MIT"
+repository = "https://gitlab.redox-os.org/redox-os/users"
+[dependencies.getrandom]
+version = "0.2"
+features = ["std"]
+
+[dependencies.redox_syscall]
+version = "0.2"
+
+[dependencies.rust-argon2]
+version = "0.8"
+optional = true
+
+[features]
+auth = ["rust-argon2"]
+default = ["auth"]