summaryrefslogtreecommitdiffstats
path: root/vendor/regex-automata/Cargo.toml
diff options
context:
space:
mode:
Diffstat (limited to 'vendor/regex-automata/Cargo.toml')
-rw-r--r--vendor/regex-automata/Cargo.toml86
1 files changed, 86 insertions, 0 deletions
diff --git a/vendor/regex-automata/Cargo.toml b/vendor/regex-automata/Cargo.toml
new file mode 100644
index 000000000..b4fcd7a0d
--- /dev/null
+++ b/vendor/regex-automata/Cargo.toml
@@ -0,0 +1,86 @@
+# THIS FILE IS AUTOMATICALLY GENERATED BY CARGO
+#
+# When uploading crates to the registry Cargo will automatically
+# "normalize" Cargo.toml files for maximal compatibility
+# with all versions of Cargo and also rewrite `path` dependencies
+# to registry (e.g., crates.io) dependencies
+#
+# If you believe there's an error in this file please file an
+# issue against the rust-lang/cargo repository. If you're
+# editing this file be aware that the upstream Cargo.toml
+# will likely look very different (and much more reasonable)
+
+[package]
+name = "regex-automata"
+version = "0.1.10"
+authors = ["Andrew Gallant <jamslam@gmail.com>"]
+exclude = ["/.travis.yml", "/appveyor.yml", "/ci/*", "/scripts/*", "/regex-automata-debug"]
+autoexamples = false
+autotests = false
+description = "Automata construction and matching using regular expressions."
+homepage = "https://github.com/BurntSushi/regex-automata"
+documentation = "https://docs.rs/regex-automata"
+readme = "README.md"
+keywords = ["regex", "dfa", "automata", "automaton", "nfa"]
+categories = ["text-processing"]
+license = "Unlicense/MIT"
+repository = "https://github.com/BurntSushi/regex-automata"
+[profile.bench]
+debug = true
+
+[profile.dev]
+opt-level = 3
+debug = true
+
+[profile.release]
+debug = true
+
+[profile.test]
+opt-level = 3
+debug = true
+
+[lib]
+bench = false
+
+[[test]]
+name = "default"
+path = "tests/tests.rs"
+[dependencies.fst]
+version = "0.4.0"
+optional = true
+
+[dependencies.regex-syntax]
+version = "0.6.16"
+optional = true
+[dev-dependencies.bstr]
+version = "0.2"
+features = ["std"]
+default-features = false
+
+[dev-dependencies.lazy_static]
+version = "1.2.0"
+
+[dev-dependencies.regex]
+version = "1.1"
+
+[dev-dependencies.serde]
+version = "1.0.82"
+
+[dev-dependencies.serde_bytes]
+version = "0.11"
+
+[dev-dependencies.serde_derive]
+version = "1.0.82"
+
+[dev-dependencies.toml]
+version = "0.4.10"
+
+[features]
+default = ["std"]
+std = ["regex-syntax"]
+transducer = ["std", "fst"]
+[badges.appveyor]
+repository = "BurntSushi/regex-automata"
+
+[badges.travis-ci]
+repository = "BurntSushi/regex-automata"