summaryrefslogtreecommitdiffstats
path: root/vendor/rowan/Cargo.toml
diff options
context:
space:
mode:
Diffstat (limited to 'vendor/rowan/Cargo.toml')
-rw-r--r--vendor/rowan/Cargo.toml57
1 files changed, 57 insertions, 0 deletions
diff --git a/vendor/rowan/Cargo.toml b/vendor/rowan/Cargo.toml
new file mode 100644
index 000000000..c717f55d0
--- /dev/null
+++ b/vendor/rowan/Cargo.toml
@@ -0,0 +1,57 @@
+# THIS FILE IS AUTOMATICALLY GENERATED BY CARGO
+#
+# When uploading crates to the registry Cargo will automatically
+# "normalize" Cargo.toml files for maximal compatibility
+# with all versions of Cargo and also rewrite `path` dependencies
+# to registry (e.g., crates.io) dependencies.
+#
+# If you are reading this file be aware that the original Cargo.toml
+# will likely look very different (and much more reasonable).
+# See Cargo.toml.orig for the original contents.
+
+[package]
+edition = "2021"
+name = "rowan"
+version = "0.15.8"
+authors = ["Aleksey Kladov <aleksey.kladov@gmail.com>"]
+exclude = [
+ ".github/",
+ "bors.toml",
+ "rustfmt.toml",
+]
+description = "Library for generic lossless syntax trees"
+readme = "README.md"
+license = "MIT OR Apache-2.0"
+repository = "https://github.com/rust-analyzer/rowan"
+resolver = "2"
+
+[dependencies.countme]
+version = "3.0.0"
+
+[dependencies.hashbrown]
+version = "0.12"
+features = ["inline-more"]
+default-features = false
+
+[dependencies.memoffset]
+version = "0.6"
+
+[dependencies.rustc-hash]
+version = "1.0.1"
+
+[dependencies.serde]
+version = "1.0.89"
+optional = true
+default-features = false
+
+[dependencies.text-size]
+version = "1.1.0"
+
+[dev-dependencies.m_lexer]
+version = "0.0.4"
+
+[features]
+serde1 = [
+ "serde",
+ "text-size/serde",
+]