summaryrefslogtreecommitdiffstats
path: root/vendor/rustc_tools_util/Cargo.toml
diff options
context:
space:
mode:
Diffstat (limited to '')
-rw-r--r--vendor/rustc_tools_util/Cargo.toml25
1 files changed, 16 insertions, 9 deletions
diff --git a/vendor/rustc_tools_util/Cargo.toml b/vendor/rustc_tools_util/Cargo.toml
index d3ec288f0..44a165131 100644
--- a/vendor/rustc_tools_util/Cargo.toml
+++ b/vendor/rustc_tools_util/Cargo.toml
@@ -3,23 +3,30 @@
# When uploading crates to the registry Cargo will automatically
# "normalize" Cargo.toml files for maximal compatibility
# with all versions of Cargo and also rewrite `path` dependencies
-# to registry (e.g., crates.io) dependencies
+# to registry (e.g., crates.io) dependencies.
#
-# If you believe there's an error in this file please file an
-# issue against the rust-lang/cargo repository. If you're
-# editing this file be aware that the upstream Cargo.toml
-# will likely look very different (and much more reasonable)
+# If you are reading this file be aware that the original Cargo.toml
+# will likely look very different (and much more reasonable).
+# See Cargo.toml.orig for the original contents.
[package]
edition = "2018"
name = "rustc_tools_util"
-version = "0.2.0"
-authors = ["Matthias Krüger <matthias.krueger@famsik.de>"]
+version = "0.2.1"
description = "small helper to generate version information for git packages"
readme = "README.md"
-keywords = ["rustc", "tool", "git", "version", "hash"]
+keywords = [
+ "rustc",
+ "tool",
+ "git",
+ "version",
+ "hash",
+]
categories = ["development-tools"]
-license = "MIT/Apache-2.0"
+license = "MIT OR Apache-2.0"
repository = "https://github.com/rust-lang/rust-clippy"
[dependencies]
+
+[features]
+deny-warnings = []