summaryrefslogtreecommitdiffstats
path: root/vendor/scoped-tls/README.md
diff options
context:
space:
mode:
Diffstat (limited to 'vendor/scoped-tls/README.md')
-rw-r--r--vendor/scoped-tls/README.md32
1 files changed, 32 insertions, 0 deletions
diff --git a/vendor/scoped-tls/README.md b/vendor/scoped-tls/README.md
new file mode 100644
index 000000000..88bd62401
--- /dev/null
+++ b/vendor/scoped-tls/README.md
@@ -0,0 +1,32 @@
+# scoped-tls
+
+[![Build Status](https://travis-ci.org/alexcrichton/scoped-tls.svg?branch=master)](https://travis-ci.org/alexcrichton/scoped-tls)
+[![Build status](https://ci.appveyor.com/api/projects/status/9tatexq47i3ee13k?svg=true)](https://ci.appveyor.com/project/alexcrichton/flate2-rs)
+
+[Documentation](https://docs.rs/scoped-tls)
+
+A Rust library providing the old standard library's `scoped_thread_local!` macro
+as a library implementation on crates.io.
+
+```toml
+# Cargo.toml
+[dependencies]
+scoped-tls = "0.1"
+```
+
+# License
+
+This project is licensed under either of
+
+ * Apache License, Version 2.0, ([LICENSE-APACHE](LICENSE-APACHE) or
+ http://www.apache.org/licenses/LICENSE-2.0)
+ * MIT license ([LICENSE-MIT](LICENSE-MIT) or
+ http://opensource.org/licenses/MIT)
+
+at your option.
+
+### Contribution
+
+Unless you explicitly state otherwise, any contribution intentionally submitted
+for inclusion in Serde by you, as defined in the Apache-2.0 license, shall be
+dual licensed as above, without any additional terms or conditions.