summaryrefslogtreecommitdiffstats
path: root/vendor/serde_json/Cargo.toml
diff options
context:
space:
mode:
Diffstat (limited to 'vendor/serde_json/Cargo.toml')
-rw-r--r--vendor/serde_json/Cargo.toml99
1 files changed, 99 insertions, 0 deletions
diff --git a/vendor/serde_json/Cargo.toml b/vendor/serde_json/Cargo.toml
new file mode 100644
index 000000000..0fb0d05d8
--- /dev/null
+++ b/vendor/serde_json/Cargo.toml
@@ -0,0 +1,99 @@
+# THIS FILE IS AUTOMATICALLY GENERATED BY CARGO
+#
+# When uploading crates to the registry Cargo will automatically
+# "normalize" Cargo.toml files for maximal compatibility
+# with all versions of Cargo and also rewrite `path` dependencies
+# to registry (e.g., crates.io) dependencies.
+#
+# If you are reading this file be aware that the original Cargo.toml
+# will likely look very different (and much more reasonable).
+# See Cargo.toml.orig for the original contents.
+
+[package]
+edition = "2018"
+rust-version = "1.36"
+name = "serde_json"
+version = "1.0.82"
+authors = [
+ "Erick Tryzelaar <erick.tryzelaar@gmail.com>",
+ "David Tolnay <dtolnay@gmail.com>",
+]
+description = "A JSON serialization file format"
+documentation = "https://docs.serde.rs/serde_json/"
+readme = "README.md"
+keywords = [
+ "json",
+ "serde",
+ "serialization",
+]
+categories = ["encoding"]
+license = "MIT OR Apache-2.0"
+repository = "https://github.com/serde-rs/json"
+
+[package.metadata.docs.rs]
+features = [
+ "raw_value",
+ "unbounded_depth",
+]
+targets = ["x86_64-unknown-linux-gnu"]
+rustdoc-args = [
+ "--cfg",
+ "docsrs",
+]
+
+[package.metadata.playground]
+features = ["raw_value"]
+
+[dependencies.indexmap]
+version = "1.5.2"
+features = ["std"]
+optional = true
+
+[dependencies.itoa]
+version = "1.0"
+
+[dependencies.ryu]
+version = "1.0"
+
+[dependencies.serde]
+version = "1.0.100"
+default-features = false
+
+[dev-dependencies.automod]
+version = "1.0"
+
+[dev-dependencies.ref-cast]
+version = "1.0"
+
+[dev-dependencies.rustversion]
+version = "1.0"
+
+[dev-dependencies.serde]
+version = "1.0.100"
+features = ["derive"]
+
+[dev-dependencies.serde_bytes]
+version = "0.11"
+
+[dev-dependencies.serde_derive]
+version = "1.0"
+
+[dev-dependencies.serde_stacker]
+version = "0.1"
+
+[dev-dependencies.trybuild]
+version = "1.0.49"
+features = ["diff"]
+
+[features]
+alloc = ["serde/alloc"]
+arbitrary_precision = []
+default = ["std"]
+float_roundtrip = []
+preserve_order = [
+ "indexmap",
+ "std",
+]
+raw_value = []
+std = ["serde/std"]
+unbounded_depth = []