summaryrefslogtreecommitdiffstats
path: root/vendor/sha2/Cargo.toml
diff options
context:
space:
mode:
Diffstat (limited to 'vendor/sha2/Cargo.toml')
-rw-r--r--vendor/sha2/Cargo.toml24
1 files changed, 13 insertions, 11 deletions
diff --git a/vendor/sha2/Cargo.toml b/vendor/sha2/Cargo.toml
index c99454e9c..ff23bdc32 100644
--- a/vendor/sha2/Cargo.toml
+++ b/vendor/sha2/Cargo.toml
@@ -3,16 +3,17 @@
# When uploading crates to the registry Cargo will automatically
# "normalize" Cargo.toml files for maximal compatibility
# with all versions of Cargo and also rewrite `path` dependencies
-# to registry (e.g., crates.io) dependencies.
+# to registry (e.g., crates.io) dependencies
#
-# If you are reading this file be aware that the original Cargo.toml
-# will likely look very different (and much more reasonable).
-# See Cargo.toml.orig for the original contents.
+# If you believe there's an error in this file please file an
+# issue against the rust-lang/cargo repository. If you're
+# editing this file be aware that the upstream Cargo.toml
+# will likely look very different (and much more reasonable)
[package]
edition = "2018"
name = "sha2"
-version = "0.10.2"
+version = "0.10.6"
authors = ["RustCrypto Developers"]
description = "Pure Rust implementation of the SHA-2 hash function family\nincluding SHA-224, SHA-256, SHA-384, and SHA-512.\n"
documentation = "https://docs.rs/sha2"
@@ -28,13 +29,9 @@ rustdoc-args = ["--cfg", "docsrs"]
version = "1.0"
[dependencies.digest]
-version = "0.10.3"
-
-[dependencies.sha2-asm]
-version = "0.6.1"
-optional = true
+version = "0.10.4"
[dev-dependencies.digest]
-version = "0.10.3"
+version = "0.10.4"
features = ["dev"]
[dev-dependencies.hex-literal]
@@ -46,6 +43,11 @@ asm-aarch64 = ["asm"]
compress = []
default = ["std"]
force-soft = []
+oid = ["digest/oid"]
std = ["digest/std"]
[target."cfg(any(target_arch = \"aarch64\", target_arch = \"x86_64\", target_arch = \"x86\"))".dependencies.cpufeatures]
version = "0.2"
+
+[target."cfg(any(target_arch = \"aarch64\", target_arch = \"x86_64\", target_arch = \"x86\"))".dependencies.sha2-asm]
+version = "0.6.1"
+optional = true