summaryrefslogtreecommitdiffstats
path: root/vendor/sha2/Cargo.toml
diff options
context:
space:
mode:
Diffstat (limited to 'vendor/sha2/Cargo.toml')
-rw-r--r--vendor/sha2/Cargo.toml41
1 files changed, 29 insertions, 12 deletions
diff --git a/vendor/sha2/Cargo.toml b/vendor/sha2/Cargo.toml
index ff23bdc32..c19f3241d 100644
--- a/vendor/sha2/Cargo.toml
+++ b/vendor/sha2/Cargo.toml
@@ -3,35 +3,51 @@
# When uploading crates to the registry Cargo will automatically
# "normalize" Cargo.toml files for maximal compatibility
# with all versions of Cargo and also rewrite `path` dependencies
-# to registry (e.g., crates.io) dependencies
+# to registry (e.g., crates.io) dependencies.
#
-# If you believe there's an error in this file please file an
-# issue against the rust-lang/cargo repository. If you're
-# editing this file be aware that the upstream Cargo.toml
-# will likely look very different (and much more reasonable)
+# If you are reading this file be aware that the original Cargo.toml
+# will likely look very different (and much more reasonable).
+# See Cargo.toml.orig for the original contents.
[package]
edition = "2018"
name = "sha2"
-version = "0.10.6"
+version = "0.10.7"
authors = ["RustCrypto Developers"]
-description = "Pure Rust implementation of the SHA-2 hash function family\nincluding SHA-224, SHA-256, SHA-384, and SHA-512.\n"
+description = """
+Pure Rust implementation of the SHA-2 hash function family
+including SHA-224, SHA-256, SHA-384, and SHA-512.
+"""
documentation = "https://docs.rs/sha2"
readme = "README.md"
-keywords = ["crypto", "sha2", "hash", "digest"]
-categories = ["cryptography", "no-std"]
+keywords = [
+ "crypto",
+ "sha2",
+ "hash",
+ "digest",
+]
+categories = [
+ "cryptography",
+ "no-std",
+]
license = "MIT OR Apache-2.0"
repository = "https://github.com/RustCrypto/hashes"
+
[package.metadata.docs.rs]
all-features = true
-rustdoc-args = ["--cfg", "docsrs"]
+rustdoc-args = [
+ "--cfg",
+ "docsrs",
+]
+
[dependencies.cfg-if]
version = "1.0"
[dependencies.digest]
-version = "0.10.4"
+version = "0.10.7"
+
[dev-dependencies.digest]
-version = "0.10.4"
+version = "0.10.7"
features = ["dev"]
[dev-dependencies.hex-literal]
@@ -45,6 +61,7 @@ default = ["std"]
force-soft = []
oid = ["digest/oid"]
std = ["digest/std"]
+
[target."cfg(any(target_arch = \"aarch64\", target_arch = \"x86_64\", target_arch = \"x86\"))".dependencies.cpufeatures]
version = "0.2"